[mythtv-users] HD-PVR extremely unstable on backend, works fine on laptop

Erik Jensen eriksjunk at laurelwoodart.com
Sun Sep 25 10:44:26 UTC 2011


I just purchased an HD-PVR to allow me to record CCI restricted
channels from my cable box. When connected to my backend, it stops
responding after capturing for 5-10 minutes, and I have to power cycle
it to get it back.

It is a Rev F2 with firmware 0x15

I have tried all of the following:
catting to mplayer
catting to a file
recording in MythTV
LiveTV in MythTV
Unloading and reloading the driver
Upgrading the firmware to 0x17 (Killed the picture color, didn't fix
the problem)
Downgrading the firmware to 0x15 again
Plugging the device into a different USB port

There are no errors reported to dmesg

When using cat, I have tried both the defaults and with the following settings:

v4l2-ctl -d /dev/video0 --set-ctrl=video_bitrate_mode=0
v4l2-ctl -d /dev/video0 --set-ctrl=video_bitrate=13500000
v4l2-ctl -d /dev/video0 --set-ctrl=video_peak_bitrate=20200000
v4l2-ctl -d /dev/video0 --set-audio-input 2

However, if I connect the device to my laptop, it seems to capture
just fine with the same settings (using cat, I don't have a
mythbackend installed).

Does anyone have an idea for tracking down the problem might be?

Thanks.

-- Erik Jensen

"Cats are intended to teach us that not everything in nature has a purpose."
  -- Garrison Keillor


More information about the mythtv-users mailing list