[mythtv-users] MythTV and Hauppage HVR-950Q

James Cobban webmaster at Jamescobban.net
Sat Sep 17 17:32:43 UTC 2011

    Date: Thu, 15 Sep 2011 22:04:20 -0500
    From: Rob Davis<rob at davis-family.info>
    Subject: Re: [mythtv-users] MythTV and Hauppage HVR-950Q
    To: Discussion about MythTV<mythtv-users at mythtv.org>
    Message-ID:<4E72BCB4.5000604 at davis-family.info>

    There are multiple types of 950Q with the same name and different
    chipsets. What revision is it? It will probably say on the sticky
    label on the underside of the usb device..

    Get the card working first, then try it with MythTV. When the computer
    boots or the card is inserted, dmesg does dmesg say? It's likely you're
    either missing firmware or something else went wrong (new card with no
    driver support).

    Do you have a /dev/dvb/xxxx tree, and if so what do you have under

    Assuming you have all this, it will appear as a dvb device in mythtv
    setup. You can follow instructions for any ATSC/QAM card.

Following Ronald Frazier's advice I get the stick assigned to /dev/dvb/adapter0/frontend0.  This informs me that the "Frontend ID" is "Auvitek AU8522 QAM/Subtype: ATSC" which is, looking at the wiki for this card, apparently the chip used in the stick.

According to the wiki the firmware for this device has been in Ubuntu since 9.10.  Since I am running 11.4 I assume that the firmware is already installed.

dmesg shows me:

[   17.640182] au0828: i2c bus registered
[   17.976480] tveeprom 14-0050: Hauppauge model 72001, rev B3F0, serial# 6778866
[   17.976486] tveeprom 14-0050: MAC address is 00:0d:fe:67:6f:f2
[   17.976490] tveeprom 14-0050: tuner model is Xceive XC5000 (idx 150, type 76)
[   17.976494] tveeprom 14-0050: TV standards NTSC(M) ATSC/DVB Digital (eeprom 0x88)
[   17.976498] tveeprom 14-0050: audio processor is AU8522 (idx 44)
[   17.976501] tveeprom 14-0050: decoder processor is AU8522 (idx 42)
[   17.976505] tveeprom 14-0050: has no radio, has IR receiver, has no IR transmitter
[   17.976508] hauppauge_eeprom: hauppauge eeprom: model=72001
[   17.993875] au8522 14-0047: creating new instance
[   17.993879] au8522_decoder creating new instance...
[   18.028174] i2c-core: driver [tuner] using legacy suspend method
[   18.028179] i2c-core: driver [tuner] using legacy resume method
[   18.029128] tuner 14-0061: chip found @ 0xc2 (au0828)
[   18.035159] xc5000 14-0061: creating new instance
[   18.040906] xc5000: Successfully identified at address 0x61
[   18.040910] xc5000: Firmware has not been loaded previously
[   18.042682] au8522 14-0047: attaching existing instance
[   18.050292] xc5000 14-0061: attaching existing instance
[   18.089532] xc5000: Device not found at addr 0x61 (0xffff)
[   18.089677] DVB: registering new adapter (au0828)
[   18.089682] DVB: registering adapter 0 frontend 0 (Auvitek AU8522 QAM/8VSB Frontend)...
[   18.090265] Registered device AU0828 [Hauppauge HVR950Q]
[   18.090337] usbcore: registered new interface driver au0828
[   18.189267] usbcore: registered new interface driver snd-usb-audio

This seems to confirm that the firmware is present and has been loaded into the stick.

The stick works fine on Windows with WinTV and picks up several stations even using the toy antenna that comes in the package.  MythTV cannot find any working channels in the range 2 to 69.

Please remember that I do not understand any of this, and I do not want to understand any of this.  I just want to record some programs.


Jim Cobban webmaster at jamescobban.net 
<mailto:webmaster at jamescobban.net?subject=Email%20Message>
Web-site: www.jamescobban.net <http://www.jamescobban.net/>
34 Palomino Dr.
Kanata, ON, CANADA
K2M 1M1

More information about the mythtv-users mailing list