[mythtv-users] Sometimes: Protocol version check failure. The response to MYTH_PROTO_VERSION was empty.

Robert Verspuy robert at exa-omicron.nl
Thu Sep 15 20:58:13 UTC 2011

Hi All,

I've been using mythtv for several years now and I'm a very happy user.
I'm currently upgrading to my 4th mythtv hardware and this will be the 
first time where I'm going to separate the backend and the frontend.

I've setup a new system with CentOS 6 (mythtv-backend 0.24.1-277.el6 
latest from atrpms repo)

MythTV Version   : v0.24.1-80-g1de0431
MythTV Branch    : fixes/0.24
Network Protocol : 63
Library API      : 0.24.20110505-1
QT Version       : 4.7.2
Options compiled in:
  linux release using_alsa using_jack using_oss using_pulse 
using_pulseoutput using_backend using_bindings_perl 
using_bindings_python using_crystalhd using_dvb using_firewire 
using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv 
using_joystick_menu using_libfftw3 using_lirc using_mheg 
using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit 
using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld 
using_xvmcw using_bindings_perl using_bindings_python 
using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads 
using_live using_mheg

But when connecting to the server from a mythfrontend running on my 
notebook I sometimes get the following error message:

2011-09-15 22:39:22.749 MythCoreContext: Connecting to backend server: (try 1 of 1)
2011-09-15 22:39:29.755 MythSocket(7fc77c0126f0:49): readStringList: 
Error, timed out after 7000 ms.
2011-09-15 22:39:29.755 Protocol version check failure.
             The response to MYTH_PROTO_VERSION was empty.
             This happens when the backend is too busy to respond,
             or has deadlocked in due to bugs or hardware failure.

In mythtv (on the backend), I've setup the ip-address and master backend 
address to
On the frontend I'm also using the same ip-address (no hostnames 
anywhere in the config).

When I run mythbackend normal (like a daemon through 
"/etc/init.d/mythbackend start"), I'm getting the "MYTH_PROTO_VERSION 
was empty" in the frontend and in mythweb at every attempt.
When I run mythbackend inside gdb, then sometimes it works without any 
problems (I can see the program guide, recorded programs in mythfrontend 
and mythweb and I can watch a recording in the frontend).

So maybe this is a timing / locking issue??
Can someone point me into where to further debug this issue?

The old backend/frontend is still running on the old hardware (although 
I've only got 5% diskspace left :) , so I can test / try anything with 
the new setup.


Robert Verspuy

More information about the mythtv-users mailing list