[mythtv-users] FW: Channel listing on mythweb from PDA broken

Anthony Rooney rooneyo at iinet.net.au
Wed Sep 14 11:18:27 UTC 2011



From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Michael Watson
Sent: Wednesday, 14 September 2011 12:40 AM
To: Discussion about MythTV
Subject: Re: [mythtv-users] FW: Channel listing on mythweb from PDA broken


On 13/09/2011 23:07, Anthony Rooney wrote: 



From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Anthony Rooney
Sent: Wednesday, 7 September 2011 8:18 PM
To: mythtv-users at mythtv.org
Subject: [mythtv-users] Channel listing on mythweb from PDA broken


Previously I used my Nokia E63 to connect to MythWeb and selected "Listings"
and then the channel to see what was scheduled on that channel at that
particular time and could scroll forward and back as required and select
recording etc.  Following the upgrade from 0.23 to 0.24 I can no longer get
listings to work from my E63 and all works as normal from any PC based web
browser client connecting to MythWeb.


Now when I select listings and then the channel I am taken to a screen with
the current date and the  Jump button with no listings below.  I cannot
figure out why this no longer works.  I downloaded a different browser to
the E63 with no good effect.  I tried the reset MythWeb template default
command from the PDA browser (?RESET_TMPL=true) which also did not work.


Everything work Ok using MythWeb from any computer or laptop based browser
but does not work anymore from the Nokia.  >From the Nokia all of the other
MythWeb functions also work fine - Upcoming Recordings, Recorded Programs
and Backend status display all the required data but not Listings.


I tried creating a second authorised user based on some feedback I found on
Google that you need a 2nd user for PDA  however ran into trouble with the
HTPASSWD command not allowing me to add a second user.  I then used the -C
option which created an new htpasswd file which has stopped Apache2 from
starting the web service I presume because it know it has a different hash.
It seems I have swallowed the spider to catch the fly trying to fix this in
the absence of any advise or assistance.


I cannot be the only one to have had listing break on PDA devices yet not


This is a very useful feature which people will want to use so how do you
get assistance or advice when it stops working?




I cannot believe I am the only one using a PDA device to access MythWeb in
the manner described so how come I get absolutely no assistance or
suggestions to help me get round such a debilitating problem using this
feature?  MythWeb is as useful as an ashtray on a motorbike or tits on a
bull if you cannot use mobile devices to load an interface that is usable.
This stopped working without reason following an "upgrade" from 0.23 to 0.24
so how do I recover this functionality??


This is supposed to be a USER forum so how do users get assistance? 

mythtv-users mailing list
mythtv-users at mythtv.org

For what its worth,

I tested the same on my Nokia E71, and get the same result as you.  
Relevent line from the Apache access.log file is:

"GET /mythweb/tv/channel/1207/20110914 HTTP/1.1" 200 1128
<> ""
"Mozilla/5.0 (SymbianOS/9.2; U; Series60/3.1 NokiaE71-1/510.21.009;
Profile/MIDP-2.0 Configuration/CLDC-1.1 ) AppleWebKit/413 (KHTML, like
Gecko) Safari/413"

Pasting into a web
browser on my desktop gives the listing for that channel as expected.  No
errors are logged in the apache error.log 

MythTV Version   : v0.24.1-84-g8f865a6
MythTV Branch    : fixes/0.24



Thanks for the feedback Michael, you are the only one that responded to this
question in over 3 weeks.  I guess there are not many people using their
mobile devices to access MythTv listings, which is very surprising.  Do you
think this is a bug and there is no work-a-round?


I have an image of my 0.23 installation which I will restore as I lost so
much with the "upgrade" to 0.24.  Perhaps my KWorld dual tuner DVB-T 160
will start working again in the old environment.  This was another question
I raised on the forum without a single suggestion to fix so I pulled out the
card in put it in a Windows machine where it works OK.  I actually thought
the card had failed not expecting a upgrade to 0.24 to kill it so


Kind Regards

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20110914/b6a8be66/attachment.html 

More information about the mythtv-users mailing list