[mythtv-users] Firewire stopped working

Obie Fayth bibendum59 at gmail.com
Mon Sep 12 21:14:17 UTC 2011


>     Just when I finally had everything working nicely I went and
> updated my system and moved the backend and cable box to a different
> room and now my firewire connection to the HD cable box has stopped
> working. Foolishly I didn't reboot the backend between the time I ran
> the yum upgrade and when I physically moved the machine. I've been
> using firewire to capture video from a Motorola DCX-3200M cable box
> for several months now and haven't had any issues until today. I
> followed the guide on the MythTV Wiki (www.mythtv.org/wiki/FireWire)
> when I originally set this up, but things are not going as smoothly
> for me this time and I'm running out of ideas for what to check.
>
> Linux version:      2.6.35.14-95.fc14.x86_64
> MythTV Version:  v0.24.1-80-g1de0431
> Motorola DCX-3200M cable box. <-- this is the only firewire device
> connected to the backend
> I'm using the built-in firewire port on my Gigabyte GA-M61P-S3 motherboard
>
> Mythbackend works fine, it is just the firewire connection that is
> broken. I have a second, analog capture card and the system is still
> happily recording using that source.
>
> I've checked all the wiring and connected the cable box to a tv to
> verify the coax to the new backend location is good. I've also changed
> the channel on the cable box to a local public access station which I
> assume is not encrypted (some of the suggestions I found said not to
> start with the box on an encrypted station). I've tried powering up
> the backend and cable box with the firewire disconnected and waited
> for them to finish booting before connecting the cable, but it doesn't
> seem to make any difference.
>
> Running firewire_tester gives me these results:
> # firewire_tester -p -n 0 -v
> raw1394: Allocating handle, port 0.
> Action: Test P2P connection 1 times, node 0, channel 0
> P2P: Testing...P2P: Creating, node 0, channel 0
> Failed
> P2P: Disconnecting.
> raw1394: Releasing handle.

After struggling with this some more I finally found the source of the
problem. I had a short coax jumper cable I was using to connect the
cable cox to the wall outlet and the center conductor was too short on
one end of the wire. I don't know if it shifted due to the way the
wire was flexed or what, but sometimes it would work when connected
and other times it would not. I swapped the wire for a spare and now
the firewire connection works perfectly once again.

I was a little surprised that firewire_tester would report a failure
when the cable box was not receiving a signal over the coax. When
using the bad coax cable and connected to a TV via composite or hdmi
the cable box would output a frozen message saying the channel would
be available shortly. Maybe it doesn't send anything over firewire in
that scenario though (I don't think any of the cable box guide info is
sent over the firewire connection).

-Obie


More information about the mythtv-users mailing list