[mythtv-users] lirc and Fedora 15 IR is slow and sometimes missing keys

Giles gbirchley at blueyonder.co.uk
Sun Sep 4 16:53:30 UTC 2011

Hi Paul,

I'm running lirc of fedora 15 and had some problems on setup. I think these problems are as a result of lirc being incorporated into the kernel: If your problems are similar to mine they can be easily resolved. First off I think you need to reinstall v4l-utils as this will contain the new scripts needed to run the ir remote. The problem will be that some of the keys will be differently named and coded to the ones in your /etc/lirc/lircd.conf

the keymaps are contained in /etc/rc_keymaps/  - look for your remote there - if it's there then you're okay.

you can checkout the new keymap with

$sudo ir-keytable -r

This will output the new scancodes for your remote eg. for me:

scancode 0x0000 = KEY_POWER2 (0x164)

...and so on

change the codes and keynames in your lircd.conf to the new versions given eg:

begin codes:
	POWER2 =  0x0164

...and so on

Also edit you .lircrc to reflect the new keynames (if any).

This worked for me with a winfast remote.


>I tried to install v4l-utils and the remote stopped working completely so I had to
>un-install to get it partially working again

On 4/09/2011 2:22 PM, Paul wrote:

> >  I tried the useEvents no luck , when I installed the v4l-utils it stopped working
> >  altogether perhaps something in that package changes how the device is presented?
> >
> >  Paul
> >
> >  On 4/09/2011 7:33 AM, Paul - subscriptions wrote:
>> >>  just upgraded to F15 from F13 where my Remote was working perfectly with MythTV, but
>> >>  after I've upgrade it seems to be active very erratic and missing keys.
>> >>  I did a quick test using 'irw' and it seems to be detecting the keys correctly but not
>> >>  consistantly.
>> >>  ie missing every other keypress which is a bit annoying if your scrolling etc...
>> >>
>> >>  my kernel is : #1 SMP
>> >>  is this a known issue?
>> >>
>> >>  Thanks

More information about the mythtv-users mailing list