[mythtv-users] Upgraded the Ubuntu 11.10 and not Myth can't connect to MySQL

Damian myth at surr.co.uk
Fri Oct 28 21:43:15 UTC 2011

Hi All,

I 'upgraded' Ubuntu last night. I wish I hadn't, but I did.

I have had the MuthBuntu package installed on top of Ubuntu for a few 
years now. I've had my share of glitches, but have been very happy for 
the last couple of years. Hopefully someone can help me get this system 
back on track.

It's a frontend/backend system I have upgraded.

If I run the frontend, it takes me to country and language and selection 
screens, then no matter what I do it says "No UPnP" and I have to click 'ok'

The backend setup suffers similarly.

If I run mythbackend from the terminal, I get this:

$ mythbackend
2011-10-28 22:23:57.233 mythbackend version: fixes/0.24 
[v0.24.1-99-gfdfc989] www.mythtv.org
2011-10-28 22:23:57.234 Using runtime prefix = /usr
2011-10-28 22:23:57.234 Using configuration directory = /home/damian/.mythtv
2011-10-28 22:23:57.234 Empty LocalHostName.
2011-10-28 22:23:57.234 Using localhost value of MythBox
2011-10-28 22:23:57.260 New DB connection, total: 1
2011-10-28 22:23:57.261 Unable to connect to database!
2011-10-28 22:23:57.261 Driver error was [1/2003]:
QMYSQL: Unable to connect
Database error was:
Can't connect to MySQL server on '' (111)

2011-10-28 22:23:59.311 UPnPautoconf() - No UPnP backends found
2011-10-28 22:23:59.311 No UPnP backends found

No UPnP backends found

Would you like to configure the database connection now? [no]
[console is not interactive, using default 'no']
2011-10-28 22:23:59.312 Deleting UPnP client...
2011-10-28 22:24:00.306 Failed to init MythContext.

Any idea what's going on?

The problem may have been caused by conflicts when I was asked to choose 
between new versions of files and older versions. Maybe I made the wrong 
choice at some stage?

Let me know where to go from here if you can.

Once I get myth working again, I'll get to putting Gnome back on. I 
didn't realise that the latest Ubuntu only had Unity, and seems to have 
removed Gnome (I can't choose it to log in with).

Thanks for any help

More information about the mythtv-users mailing list