[mythtv-users] Unexpected interaction between Mythfrontend and K3b

John Pilkington J.Pilk at tesco.net
Thu Oct 27 17:53:02 UTC 2011

On 27/10/11 17:39, Michael T. Dean wrote:
> On 10/26/2011 02:52 PM, John Pilkington wrote:
>> On 26/10/11 18:37, Michael T. Dean wrote:
>>>> K3b used with no Notifications active, sound playback continued without
>>>>>> interruption. K3b defaults need revising; will add this to KDE bug report.
>> <snip>
>>> What happens if you change MythTV to use PulseAudio directly instead of
>>> ALSA?  (And, if that "works"--prevents audio failure during burning, you
>>> can either use it like that--and likely get those beeps and blings and
>>> ... during playback--or just get rid of PulseAudio completely.)
>> Mike:  The system as I have it now seems to work OK so I don't feel a
>> strong need to mess with PulseAudio options.  I'll keep an eye on the
>> logs and see if it continues to be switched on and off.  I see mild A/V
>> sync issues with vlc that may be PA related, too, so I'll maybe try
>> disabling it sometime... but not yet!
> The MythTV logs will only mention when MythTV enables/disables
> PulseAudio--they won't mention when PulseAudio is automatically
> re-enabled by the server to handle a non-MythTV request.
> I just thought it was worth exploring so that you could close the k3b
> bug report if it turns out it's not doing anything and it's actually
> Pulse--and the fact that you've configured ALSA instead of Pulse on your
> MythTV--that's causing the problem.  It should be easy enough to
> test...  Find the audio output device setting, write down its current
> value, change it to the proper one for PulseAudio's default device, then
> test--then, if you want, change it back to the ALSA value you have now.
> Mike

Mike:  I tried PulseAudio:Default   That and NULL are the only non-ALSA 
devices that I'm offered.  Results seemed unpredictable, usually loud 
white-ish noise but with occasionally tolerable sections.  I had a lot 
of problems with sound earlier.  Using ALSA:front:CARD=Intel,DEV=0 
hasn't given significant problems recently - except perhaps for this 
bug.  A similar bug has been reproduced elsewhere on f16 and is being 
worked on.  On my system this bug is no longer troublesome. The 
'undefined sound file' was probably a Fedora upgrade artefact that was, 
AFAIK, properly reset as soon as I tried making changes to the 
Notification settings.  I don't think I have more to add to the process 
at this stage.  Sorry :-)

But I do have another question that I'll send off shortly...


More information about the mythtv-users mailing list