[mythtv-users] Lossless Transcode Issue

Scott and Nicole Harris snharris99 at live.com
Wed Oct 26 14:54:58 UTC 2011

I have a bunch of shows that I don't watch immediately (I save them until summer rerun season), so for the sake of space, I cutlist the commercials, then do a lossless transcode to remove the commercials.  Over the years, I have had the odd transcode fail here and there, which is no biggie.  However, over the last 2 weeks, I have a had a couple instances where the transcode does not fail, but the resulting file is much bigger than the original (as in 6GB -> 20GB), the reported length of the resulting file is 3x what it should be (42mins -> 1:25), the audio is gone and the video is incredibly interlaced and pixelated.
The mythbackend is littered with the following messages. This is from the last problematic transcode (it just keeps repeating these same two errors over and over with only the ", 423967636" part changing....
QString::arg: Argument missing: "Frame 9 > 8. Corruption likely at pos: 8" , 4239676362011-10-25 07:08:08.688 Frame 9 > 8. Corruption likely at pos: 82011-10-25 07:08:08.770 Inserting 2 I-Frames after #82011-10-25 07:08:09.038 Inserting 2 I-Frames after #14QString::arg: Argument missing: "Frame 21 > 20. Corruption likely at pos: 20" , 4243143082011-10-25 07:08:09.088 Frame 21 > 20. Corruption likely at pos: 202011-10-25 07:08:09.172 Inserting 2 I-Frames after #202011-10-25 07:08:13.366 Inserting 2 I-Frames after #26
The original file (though I didn't watch the entire thing before transcoding) seemed fine.
Has anyone else had this issue, or have any suggestions?  In a case like this, wouldn't it be prudent to abort with a failure the trascode so as to not destroy the original?

More information about the mythtv-users mailing list