[mythtv-users] HDHR Prime recordings of Discovery HD - particularly bad?

Ronald Frazier ron at ronfrazier.net
Mon Oct 24 18:51:41 UTC 2011

On Mon, Oct 24, 2011 at 10:10 AM, Robert Kulagowski <rkulagow at gmail.com> wrote:
> Is anyone else finding that their recordings of Discovery Channel HD
> are corrupted?  They are playable in MythTV and in mplayer, but at
> least on my system there's something wrong with the headers, because
> the built-in lossless transcode fails to work, as do external programs
> such as projectx and gopchop.
> This occurs on every single program I record on Discovery HD, but not
> on other channels.

I haven't tried on Discovery HD, but last month I had a similar
problem with Science HD (which, coincidentally, is owned by
I tried to use mythtranscode to strip commercials with its lossless
transcode feature, and it failed. I don't recall the specific error I
got in the log files, but it led me to believe it was something
unsupported in the file format. I use that feature often on other
channels and it works perfectly. I've still got the recordings just
sitting on my hard drive at the moment waiting for me to get around to
figuring out what the issue was. I haven't yet tried any other

Coincidentally, I've noticed many (perhaps all) of the recordings off
of Science HD have an incorrect length. Myth (I'm on 0.24) usually
calculates the file as being 2 to 5 minutes shorter than it actually
is. Have you noticed any issues like that on Discovery? Could be 2
symptoms of the same cause.

Ron Frazier

More information about the mythtv-users mailing list