[mythtv-users] mythbackend.log no longer records output of user scripts under that which will become 0.25. Workaround?

Douglas Peale Douglas_Peale at comcast.net
Sat Oct 22 22:53:24 UTC 2011

I am trying to fix the checklogin.sh script that was broken by the upgrade to 11.10.
Under 0.24 and earlier an "echo lots of text" in a user script would include the "lots of text" in the mythbackend.log file
Under that which will become 0.25, none of the echoed text shows up in the log file.

I tried "echo lots of text >>/home/user/local.log" in the script, but though this works when I run the checklogin.sh from the
command line, it does not work when the script is run by mythbackend. (script runs, I can see the behavior, but no debugging
text gets recorded).

I'm obviously doing something wrong, but what I'm doing wrong is not obvious to me.

Is this a permissions problem? If so, what directory is mythbackend allowed to write in?

What is the proper way for my script to add text to the mythbackend.log. Should I even be writing to the mythbackend.log? If
not, how do I create my own log file?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
Url : http://www.mythtv.org/pipermail/mythtv-users/attachments/20111022/e809b497/attachment.bin 

More information about the mythtv-users mailing list