[mythtv-users] Mythbuntu 11.10 budget-ci IR doesn't work with LIRC nor inputlircd

Doug Scoular dscoular at cisco.com
Thu Oct 20 10:41:46 UTC 2011

Hi All,
     I'm afraid my clean upgrade to Mythbuntu 11.10 hasn't gone quite as 
smoothly as I'd have hoped. At the moment my main issue is that I cannot 
get my Hauppauge Nova-T grey remote control talking to either LIRC 
(devinput) nor inputlircd. The weird thing is that evtest shows my 
button presses but irw doesn't see them. Even stranger is the fact that 
irrecord has no problem seeing the presses and generating a config file 
which still doesn't get lircd working. I'm specifying devinput as the 
REMOTE_DRIVER and using my configs which worked on 11.04. After giving 
up on that I thought I could switch to inputlircd and all would be well 
but, no, even though evtest is showing keypresses inputlircd and irw are 
still silent.

I've googled till I'm blue in the face and the only thing I've come 
across is a bit about having to echo lirc > /sys/class/rc/rc0/protocols 
but still no joy there.

evtest gives me the following when I hit the 1, 2, 3 keys:

root at spug:/home/dug# evtest
No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0:      Power Button
/dev/input/event1:      Power Button
/dev/input/event2:      AT Translated Set 2 keyboard
/dev/input/event3:      Budget-CI dvb ir receiver saa7146 (0)
/dev/input/event4:      iMON Panel, Knob and Mouse(15c2:ffdc)
/dev/input/event5:      iMON Remote (15c2:ffdc)
/dev/input/event7:      IR-receiver inside an USB DVB receiver
/dev/input/event8:      HDA Intel HDMI/DP,pcm=3
/dev/input/event9:      HDA Intel Headphone
Select the device event number [0-8]: 3
Input driver version is 1.0.1
Input device ID: bus 0x1 vendor 0x13c2 product 0x1011 version 0x1
Input device name: "Budget-CI dvb ir receiver saa7146 (0)"
Supported events:
   Event type 0 (Sync)
   Event type 1 (Key)
     Event code 2 (1)
     Event code 3 (2)
     Event code 4 (3)
.... truncated for brevity ....
     Event code 403 (ChannelDown)
     Event code 405 (Last)
     Event code 412 (Previous)
   Event type 4 (Misc)
     Event code 4 (ScanCode)
   Event type 20 (Repeat)
Testing ... (interrupt to exit)
Event: time 1319106200.469376, type 4 (Misc), code 4 (ScanCode), value 1f01
Event: time 1319106200.469378, -------------- Report Sync ------------
Event: time 1319106200.583586, type 4 (Misc), code 4 (ScanCode), value 1f01
Event: time 1319106200.583588, -------------- Report Sync ------------
Event: time 1319106201.847405, type 4 (Misc), code 4 (ScanCode), value 1f02
Event: time 1319106201.847406, -------------- Report Sync ------------
Event: time 1319106201.961532, type 4 (Misc), code 4 (ScanCode), value 1f02
Event: time 1319106201.961533, -------------- Report Sync ------------
Event: time 1319106202.075724, type 4 (Misc), code 4 (ScanCode), value 1f02
Event: time 1319106202.075726, -------------- Report Sync ------------
Event: time 1319106203.550619, type 4 (Misc), code 4 (ScanCode), value 1f03
Event: time 1319106203.550621, -------------- Report Sync ------------
Event: time 1319106203.664783, type 4 (Misc), code 4 (ScanCode), value 1f03
Event: time 1319106203.664785, -------------- Report Sync ------------
Event: time 1319106203.778874, type 4 (Misc), code 4 (ScanCode), value 1f03
Event: time 1319106203.778875, -------------- Report Sync ------------

     My suspicion is that this shouldn't be outputting the (Misc) scan 
codes... but I'm stumped... another worry is that ir-keytable seems to 
think that my budget-ci IR on my aging Nova-T supports No protocols!

root at spug:/home/dug# ir-keytable
Found /sys/class/rc/rc0/ (/dev/input/event3) with:
         Driver budget_ci, table rc-hauppauge
         Supported protocols:
         Enabled protocols:
         Repeat delay = 500 ms, repeat period = 125 ms

     There's also no locking conflict (mentioned as a problem by others) 
with hal since hal isn't installed on mythbuntu 11.10.

     I've tried strace of lircd, irw and also with inputlircd but all to 
no avail - they are using the correct socket and config files. I had no 
problems figuring out lircd under 11.04 but 11.10 has got me stumped!

     Any hints, clue, advice or sympathy much appreciated.



More information about the mythtv-users mailing list