[mythtv-users] Failed to Scan SG Video Hosts Error

Roger Horner roger1818 at yahoo.com
Thu Oct 20 00:04:06 UTC 2011

On 10/17/2011 8:48 PM, Michael T. Dean wrote:


Thanks Mike!  I found what I needed to solve the problem.

Just to close the loop and explain the solution for others that follow, under "If you no longer have access to the to-be-retired backend system" it says, "In mythtv-setup on the master backend system (it must be the master 
backend system), go into Storage Directories, and Delete each Storage 
Group (select the group and hit DELETE (by default, 'D'))."  I don't have any storage groups (other than default) set up anymore, so I had to create one before it would let me do the delete.  So far I have only done this Videos Storage Group but I guess I should do it for the other types of storage groups to make sure they are clean as well (though I gather the Videos Storage Group is most likely to have overrides that need deleting "since MythVideo requires an explicit override of the Videos Storage 
Group on each host.").

Optimally I should have renamed the new backend to use the same name as the old one immediately after restoring the database and before running mythtv-setup (MythTV doesn't seem to like you changing the name of your backends).  This would have prevented me from having a bunch of other problems that I had to fix.  If you want to change the name, you have to go through the procedure of "Retiring an old backend," but that adds a lot of work as you have to reconfigure all your capture cards and all your storage groups.  Hardly worth it for just a name.

Thanks again,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20111019/d4f80fd1/attachment.html 

More information about the mythtv-users mailing list