[mythtv-users] Mythfilldatabase is REALLY slow.

James MacKenzie mst3000 at newsguy.com
Sun Oct 9 04:30:03 UTC 2011

On 10/8/2011 11:19 PM, linux guy wrote:
> With regards to ext4 being a barrier to mysql performance, that should 
> be added to HOWTO and maybe a FAQ.
> Prior to formatting my disks, I spent several hours reading various 
> threads on JFS, etc.   Not once was mysql performance mentioned wrt ext4.
> Very interesting.

This seems to be true (in Fedora, at least) for xfs as well, not just ext4.

I had been running the -fixes branch in Slackware 13.37 using xfs.  All 
worked fine and pretty quickly, too.

I had a problem (mentioned recently on this mailing list) with my remote 
control in Slack so I switched to Fedora 15.  I installed using xfs 
since it is my fs of choice.

I was able to get things working but when I tried mythfilldatabase, the 
drive light went on solid, my loadav went up pretty high and it just sat 

I reformatted the partition into ext4, thinking that might fix the 
problem, but no, it did the exact same thing, light on solid, etc.  So, 
I asked on here and was told to try ext3.

Just so everyone knows, yes...that fixed the problem.  And thanks to 
everyone who helped me.

One thing I *did* notice, is that it is slower than my previous 
Slack13.37/xfs setup.  I'm not sure if it is the more recent version of 
MySQL with Fedora, or not...but, I did want to let people know that xfs 
can be problematic as well.

More information about the mythtv-users mailing list