[mythtv-users] Pauses every 10 seconds - playback of active recordings only

Matthew Hubbard hubrat at gmail.com
Tue Oct 4 04:01:42 UTC 2011

Hi all, apologies in advance for the essay - just trying to be detailed.

First up, I've read through the thread on random short pauses here
and in reference to Michael Dean's post on 23 May I sometimes notice
#1 and often notice #3

I have a combined BE/FE and my biggest issue is playing back a
recording that is still in progress. Every 10 seconds, the video and
audio will pause for a second. If I skipped back, the pause is in a
different place so the underlying recording is ok. Once the recording
has finished, the recording plays back fine.

Live tv is fine, I can pause and skip around without issue. Previously
recorded programs are ok while another is in progress. I even had 8
recordings going at once and played back a 9th show without issue.
Once the 8 were finished they were ok but if I tried to watch while
they were still recording I got these pauses.

If I exit the frontend and find the still recording file, I can play
it back in another player such as vlc without issue.

Some system specs,
Arch linux 3.0 kernel
nvidia 280.13-1
2GB ram

The pauses were coinciding with this entry in the frontend log
ALSA, Error: WriteAudio: buffer underrun
until I bumped the vdpau buffer from 32 to
which generally removed the ALSA buffer underrun entry.

Audio pauses are now almost unnoticeable but the picture still freezes
every 10 seconds or so.

This is a logfile with options -v audio,playback and vpdaubuffersize=32
A recording was already underway so I went to it and played it.

This is a logfile with options -v audio,playback and vpdaubuffersize=50
No recordings were active so I started live tv, waited for a pause at
the program boundary around line 417 of the log, pressed record,
exited to the menu and then started playback of the recording.

Watching iotop there appear to be a burst of mysql processes that
align with the pauses I'm seeing during playback but they are also
there during live tv without any interruptions to playback.

I've already followed the mysql tweaks from

Other things I've already tried that were unsuccessful

Increase ringbuffer to max size
Moved the recordings directory to a separate physical drive and not in an LVL
Re-nice frontend and backend processes
Run both frontend and backend as root instead of a normal user
Double check all audio settings and buffers
Removed pulse audio
Changed playback profiles to no vdpau and also tried ffmpeg decode
with vdpau render
Changed from 0.24.1 to 0.24-fixes to jyavenard/backports/fixes/0.24 to master
Watching top during playback for anything unusual

If this was a mythtv bug I'd expect more widespread reporting. Either
I'm the only one with this issue or my google skills aren't up to

Are there any other suggestions or fixes I can try?

Thanks in advance,

More information about the mythtv-users mailing list