[mythtv-users] Recording issues with I/O load

Jason umproko5 at gmail.com
Sat Oct 1 13:57:14 UTC 2011

On 09/21/2011 03:51 AM, Stefan Lands wrote:
> Hello,
> I'm trying to find help in solving an issue with my new mythtv-box. I've
> been using mythtv for a couple of years by now, but this time I'm having
> a problem which I cannot solve. I'm out of ideas.
> My last mythtv-box used to be a AMD6000+ powered system, which ran fine
> over the years. But in the meantime the electrical-bills got higher from
> year to year, so I thought of building a new system, which takes much
> less energy to run 24/7. So I bought pretty new hardware:
> - ASUS E35 M1-M Pro with 4GB RAM
> - 1x SATA-HDD (which contains Ubuntu 10.04 as well as the
> mythtv-recording-directories)
> - 3x SATA-HDD (SW-RAID5 containing many archived recordings I wanna keep)
> - 1x DVB-C TT C-1500 (moved from the old system)
> - mythtv 0.23.0+fixes
> Well, when the new system runs for itself, theres no problem at all,
> recordings are pretty well. But as soon as I'm starting streaming an
> archived recording from the RAID to my TV (no matter if I do this via
> NFS, UPnP or Samba) the recordings get bad. There are a lot of artefacts
> and audio glitches in the recording. As soon as I stop streaming this
> 'noise' vanishes immediately. The same happens, when I'm  just copying
> an archived recording to my notebook for example, or when I'm md5summing
> any archived video-file on the RAID. It happens every time when I
> generate any mentionable I/O load to the system.
> It happens not, when I'm copying Files from external USB-HDD to the RAID.
> I've searched this list and other for an explanation to this, but what
> I've found on this topic are really old threads like this one:
> http://www.gossamer-threads.com/lists/mythtv/users/159591 or this one:
> http://pchdtv.com/forum/viewtopic.php?p=6378
> These guy's troubles seem to be at least partially to be the same as
> mine, except for the fact, that I have different hardware. In these and
> other threads people are talking about RF-noise or EMI causing bad
> reception to the tuner of the DVB card, when there's a higher I/O load
> to the system. Others are suggesting playing with the PCI-latency as
> described here: http://www.mythtv.org/wiki/PCI_Latency
> What I did:
> - I've tried playing around with the latency but without any effect. As
> far as I'm understanding this, the SATA-controller is connected to the
> PCIe, which is independent from the PCI-bus which holds the DVB-adaptor.
> So it makes really sense to me that playing with the latency doesn't
> have any effect on this issue.
> - I've observed the reception level using femon while recording and
> streaming the same time ->  didn't see anything suspicious.
> - I deactivated the onboard Realtek R8168 in BIOS and replaced it with
> an Intel PCIe GBit card ->  no effekt
> - I shut down mythtv-backend and tried DVB live-tv with me-tv ->  same
> effekt, picture gets corrupted
> What I've observed:
> - CPU-load never seemed to be at any critical rate while recording and
> streaming
> - Playing around with different Kernels from 2.6.32 to 2.6.38 - no
> matter if with their own dvb-modules or newest ones from linuxtv.org -
> it makes no difference
> - There are only few BIOS-versions available for this board. No matter
> which one I try, it makes no difference at all
> - syslog shows no errors
> - backend.log contains many errors of these: 2011-09-18 21:33:59.617
> Error: offset>181, pes length&  current can not be queried. Except for
> these there are no other errors during recording and streaming at the
> same time
> - frontend.log contains errors like the following during playback,
> resulting from the corrupt data:
> 2011-09-19 14:43:45.334 [ac3 @ 0x8699960]frame sync error
> 2011-09-19 14:43:45.334 AFD Error: Unknown audio decoding error
> 2011-09-19 14:43:45.860 [ac3 @ 0x8699960]frame CRC mismatch
> 2011-09-19 14:43:45.860 [ac3 @ 0x8699960]frame sync error
> 2011-09-19 14:43:45.860 AFD Error: Unknown audio decoding error
> 2011-09-19 14:43:46.360 WriteAudio: buffer underrun
> 2011-09-19 14:43:46.367 [ac3 @ 0x8699960]frame CRC mismatch
> 2011-09-19 14:43:46.368 [ac3 @ 0x8699960]frame sync error
> 2011-09-19 14:43:46.368 AFD Error: Unknown audio decoding error
> 2011-09-19 14:43:46.370 [ac3 @ 0x8699960]frame CRC mismatch
> 2011-09-19 14:43:46.618 [ac3 @ 0x8699960]frame sync error
> Well, I'm out of ideas now what to try or change else. There's another
> system I built running fine in my family with the same Motherboard and
> the same software-configuration. The only difference is the DVB-setup
> consisting of  2x Mystique SaTiX DVB-S-PCI-cards (KNC-One clone).
> I know that the C-1500 in my system is rather old, but in the old
> AMD6000 it worked fine.
> I would be happy for suggestions which help me to find out what causes
> these problems. Or what can I do to dig deeper in my system to find the
> root of all evil.
> Thanks for your help.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users
try installing,

to see what is causing the IO.


More information about the mythtv-users mailing list