[mythtv-users] Seriously need help fixing new setup

R. G. Newbury newbury at mandamus.org
Tue Nov 22 16:17:22 UTC 2011

On 11/22/2011 03:34 AM, Michael T. Dean wrote:
> On 11/21/2011 05:07 PM, R. G. Newbury wrote:

>> ">   That is correct--there shouldn't be a hostname associated with
>>    >   MasterServerIP."
>> Huh??  Interesting. I have four standalone myth setups atm (including
>> the F16 setup presently being poked and prodded in a virtual on the
>> laptop). All of them have a host entry for the MasterServerIP row (along
>> with the IP address of course).
> The point is that the MasterServerIP can /not/ be different on any of
> the hosts--it has to be the same everywhere.  It's a global setting so
> the hostname should be NULL.  If we stored it with a hostname, different
> hosts could see different values for MasterServerIP.

> MythTV doesn't rely on any form of external name-based address
> resolution.  All addressing of requests is done using data in the MythTV
> configuration.  However, MythTV /does/ rely on each host having a unique
> identifier that we can use to store its settings/configuration--and we
> use the host name, as provided by the system, unless the user creates an
> override and specifies their own identifier.

All of that makes perfect sense. And the presence of a hostname on my 
systems is an error which I will correct. Of course, it is a benign 
error on any standalone BE/FE setup, which is why its has never bitten 
me. It would if I made the laptop an FE to the main mythbox...


More information about the mythtv-users mailing list