[mythtv-users] Seriously need help fixing new setup

R. G. Newbury newbury at mandamus.org
Tue Nov 15 16:21:14 UTC 2011

On 11/14/2011 08:30 PM, networks1 at cox.net wrote:

> config.xml says the db is mythconverg.  When I try to configure with mythfrontend -p it starts and exits, and in the terminal window there is:
> QGtkStyle was unable to detect the current GTK+ theme.
> Qt: Session management error: None of the authentication protocols specified are supported
> 2011-11-14 18:25:50.063 mythfrontend version:  [0.24.1-2.fc15 (3657f313ac)] www.mythtv.org
> 2011-11-14 18:25:50.063 Using runtime prefix = /usr
> 2011-11-14 18:25:50.063 Using configuration directory = /root/.mythtv
> 2011-11-14 18:25:50.063 ThreadPool:HTTP: Initial 1, Max 25, Timeout 60000
> 2011-11-14 18:25:50.667 Unable to read configuration file mysql.txt

This time you are running as root and there is no 'mysql.txt' file in 
/root/.mythtv  You need a symlink to /etc/mythtv/mysql.txt.

Regarding the QGtkStyle error, install the qt-config package. Then run 
qtconfig-qt4 and select a style from the dropdown. I have no idea why 
this error should arise. It did not in Fedora14 and I did not see it on 
my laptop with F15. You may have omitted to install the qt-x11 package 
which carries most of the infrastructure which is adjusted by the 
qtconfig-qt4 gui.


More information about the mythtv-users mailing list