[mythtv-users] Playback Pauses and MySQL

Ray Parrish rparrish at gmail.com
Wed May 18 18:53:44 UTC 2011

On my main Frontend/Backend, I have been experiencing the same long
pauses during playback that others have. On this system specifically,
I have tracked down the pauses to database-intensive activity,
specifically running mythlink.pl. I have a cron job set to run at 5
and 35 minutes past the hour with these arguments:

mythlink.pl --link /mythtv/names --format "\%T \%- \%Y-\%m-\%d \%-
\%g-\%i \%A \%- \%S"

When it runs, playback hangs for a good 20-30 seconds. I have tried
enabling and disabling the MySQL tweaks from the Mythbuntu Control
Center with no change in the behavior. This also happens no matter if
there are recordings/commflag jobs in progress, though in a couple of
instances it has interfered with the progress of commflagging multiple

I believe that I should be able to change the MySQL configuration to
be more friendly, but I am not certain how. Any pointers?

MythBuntu Lucid
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
RAM: 2GBytes
OS/DB drive is PATA 300GB (not sure of rotation speed, believed 7200rpm)
Recordings on separate SATA drives using Storage Groups
369 current recordings stored

MythTV Version   : v0.24.1-1-g347cd24
MythTV Branch    : fixes/0.24
Network Protocol : 63
Library API      : 0.24.20110505-1
QT Version       : 4.6.2
Options compiled in:
 linux debug using_alsa using_oss using_pulse using_pulseoutput
using_backend using_bindings_perl using_bindings_python using_directfb
using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr
using_iptv using_ivtv using_joystick_menu using_lirc using_mheg
using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit
using_v4l using_v4l2 using_x11 using_xrandr using_xv
using_bindings_perl using_bindings_python using_mythtranscode
using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg


More information about the mythtv-users mailing list