[mythtv-users] Playback problem -- random short pauses

Kenneth Emerson kenneth.emerson at gmail.com
Tue May 17 18:43:12 UTC 2011

On Tue, May 17, 2011 at 11:49 AM, Steven Adeff <adeffs.mythtv at gmail.com>wrote:

> On Fri, May 6, 2011 at 9:46 AM, Kenneth Emerson
> <kenneth.emerson at gmail.com> wrote:
> > Last night I modified the routine RingBuffer.cpp
> > (method: RingBuffer::CalcReadAheadThresh) to always choose the largest
> read
> > block size.  Whether this was a proper change or not it did seem to
> > eliminate the pauses I had been seeing.  I watched approximately four
> hours
> > of recordings without any pausing of the video or audio.  I will leave
> this
> > change in for a week to see if it has really solved the symptoms (if not
> the
> > problem). At that point I might open a ticket with the patch.
> > Here is the diff for anyone else brave enough to give it a try:
> > diff --git a/mythtv/libs/libmythtv/RingBuffer.cpp
> > b/mythtv/libs/libmythtv/RingBu
> > index 8b59616..d4613d6 100644
> > --- a/mythtv/libs/libmythtv/RingBuffer.cpp
> > +++ b/mythtv/libs/libmythtv/RingBuffer.cpp
> > @@ -816,7 +816,10 @@ void RingBuffer::CalcReadAheadThresh(void)
> >      rbs            = (estbitrate > 5000)  ? KB128 : rbs;
> >      rbs            = (estbitrate > 9000)  ? KB256 : rbs;
> >      rbs            = (estbitrate > 18000) ? KB512 : rbs;
> > -    readblocksize  = max(rbs,readblocksize);
> > +    // readblocksize  = max(rbs,readblocksize); Ticket #8706:
> > 8706_debug.diff
> > +    //  Try to maximize readahead buffer. By KRE 05/04/2011
> > +    rbs = KB512;
> > +    readblocksize  = rbs;
> >      // minumum seconds of buffering before allowing read
> >      float secs_min = 0.25;
> > Regards,
> > Ken E.
> Ken, any word on how the patch worked out after a week of use?
> Unfortunately, this patch provided no relief.  I have since backed out the
change. I haven't been diligent in trying to correlate all of the pauses to
external events, but the ones that I have chased down seem to align with
other commenters in this thread.  I definitely see pauses when recordings
start/stop in the backend.  I also see pauses when auto-expire occurs and
files get deleted as well as when the preview image is being constructed.  I
do have the WD green drives, but I checked the SMART parameters for head
parking and that is not the issue (slightly more head parks than power
cycles and < 100 for three year old drives).

I still believe that something has changed as this wasn't a problem until
sometime in .24-fixes (guessing within the last three months).  Someone in
this thread suggested going back to when .24 was forked off (last db
update).  Kenni and Jean-Yves both seemed to have tried going backward and
were not able to locate where the problem surfaced (thinking it was pre .24

I am on the verge of upgrading to 0.25 head hoping that most of the core
changes for the 0.25 release have been made and that head is somewhat stable
as this is the family's only DVR.  It also might be useful if people who are
seeing this problem report their configuration to see if there is any
commonality in hardware and/or software.  I am assuming that not everyone
is experiencing this problem.  So I will start:


    Motherboard:  P5K-E/WIFI-AP LGA 775
    CPU: Core 2 Quad Q6600 Kentsfield 2.4GHz
    Memory:  4GB DDR2 1066
    Disk:  4 x Western Digital Caviar Green WD10EACS 1TB SATA 3.0Gb/s
              1 x  Western Digital WD5000KS 500GB SATA (sdf)
    TV: Hauppauge HVR-1800 PCIe
           Hauppauge PVR-250  PCI
           Hauppauge PVR-350 PCI

>      HDHR dual tuner
        Hauppauge HDPVR v 0x12


     OS: Ubuntu 10.04.02 LTS (32 bit)
     Kernel: 2.6.32-31-generic #61-Ubuntu SMP
     Other packages:
         exim4 mail server
         apache2 web server
         samba v3.4.7
         smartd v5.38
         all mythtv scripts run by cron between 3am and 5am except for
mythfilldatabase and mythcal which are run back-to-back between 5pm and 6pm.

     MythTV combined FE/BE (no other computers)
     Drive partition:
     sda1/sdb1/sdc1/sdd1 -> RAID1 boot ext3
     sda2/sdb2/sdc2/sdd2 -> RAID1 root ext3
     sda3/sdb3/sdc3/sdd3 -> RAID1 swap
     sda4/sdb4/sdc4/sdd4 -> RAID5 LVM xfs (recordings)
     sdf1 -> mysql database

    mythfrontend running from xinit and gnome
    mythbackend running with debug v0.24.1-1-g347cd24-dirty (in the process
of removing all edits)

> -- Ken E.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20110517/e53a7f43/attachment.html 

More information about the mythtv-users mailing list