[mythtv-users] Playback problem -- random short pauses

Kenneth Emerson kenneth.emerson at gmail.com
Tue May 3 17:46:48 UTC 2011

On Tue, May 3, 2011 at 6:28 AM, Steve Curtis <scurtis at fixation.net> wrote:

> On 24 March 2011 15:03, Kenneth Emerson <kenneth.emerson at gmail.com> wrote:
>> I have been following several of the threads on this list (and the commit
>> list) that have talked about "stuttering" during playback.
> I get this too.  I notice that it will always stutter in between programmes
> such as when the news is about to start - almost without fail.  This leads
> me to think that it must be recording related as one programme ends and new
> one starts.
IIRC, there have been numerous complaints about pauses/stuttering while
watching recordings when other recordings started/stopped.  This is really
starting to look like disk contention where the recording being watched is
not buffering enough to get through the (perfect storm?) disruption.  I
haven't studied the code that much, but I believe this is what is called the
"Ring Buffer"?  I have seen several commits regarding the size of it, and I
was asked (by Taylor Ralph) to apply a patch that affected how the size was

Maybe one of the devs can point me to a place where I can try making this
larger or at least putting some debug in to see if this is the problem.

-- Ken E.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20110503/cda9ecc6/attachment.html 

More information about the mythtv-users mailing list