[mythtv-users] Do you build mythtv from source, and why?

Neil Cooper neilcoo at yahoo.co.uk
Tue Mar 29 18:09:04 UTC 2011

--- On Tue, 3/29/11, Mark Lord <mythtv at rtr.ca> wrote:

> From: Mark Lord <mythtv at rtr.ca>
> Subject: Re: [mythtv-users] Do you build mythtv from source, and why?
> To: "Discussion about MythTV" <mythtv-users at mythtv.org>
> Date: Tuesday, March 29, 2011, 9:31 AM
> On 11-03-29 12:01 PM, Mark Lord
> wrote:
> ..
> > Speaking of Mythbuntu -- it would be Really Nice if
> somebody there could
> > take a look at the Upstart startup/shutdown
> sequence.  It mostly works
> > by accidents of timing, and doesn't work at all in the
> system I have here,
> > with the rootfs on a very very fast SSD.  That
> throws the timing way off.
> ..
> Note:  I'm one of the (probably few) Mythtv users who
> actually
> has their Mythtv box power down between
> recordings/viewings,
> using the RTC to wake it up again in time for the next
> recording.
> So this box does a lot more boots/shutdowns than most
> Mythtv boxes,
> making any glitches in the sequence much more apparent.
> Cheers
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users

Hi Mark,

All the patches you mention sound very useful. Would you consider releasing them into the wild somehow? (c) and (e) are particularly annoying for me and its great you have fixes. I really miss the old options that used to exist whereby you could specify the EPG size and the OSD timeouts.

>> (b) fix/improve various issues with the mythtbuntu theme.
>> (c) enlarge the EPG to have more rows/columns on my 1080p screens.
>> (d) show tuner name in signalmon display, and when changing channels (useful for
>> OTA).
>> (e) shorten the OSD timeouts, so they don't cover up playback for as long.

BTW I set my box exactly the same to powerup-on-demand as you do.
I can't seem to get mythwelcome to not launch the frontend even when the box is woken up automatically though, so I have to either disable the fronted-autostart function entirely or accept the box not shutting itself down after an automatic recording. 

 Did you happen to encounter the same problem? and even possibly find a fix?

More information about the mythtv-users mailing list