[mythtv-users] PVR150 IR Problems

DeKay dekaymail at gmail.com
Sun Mar 20 03:17:50 UTC 2011

I am having problems getting my myth box and LIRC after a kernel and
LIRC upgrade.  /dev/lirc0 is created.  irw shows me some keys from my
remote, but only some.  A few numbers don't work, the direction pad
doesn't work, etc.  Operation seems somewhat intermittent as well: a
keypress will sometimes register with irw and sometimes it won't, or
it will be sluggish.  I am using the latest software in the Arch Linux
repositories.  mode2 spits out data for every single keypress

Some pertinent details:

[root at mythbox ~]# uname -r
2.6.37-ARCH  (actually kernel26-

[root at mythbox ~]# lsusb
Bus 002 Device 003: ID 1784:0001 TopSeed Technology Corp. eHome
Infrared Transceiver

[root at mythbox ~]# lsmod |grep lirc
ir_lirc_codec           3559  3
lirc_mceusb            12977  0
lirc_dev                8091  2 ir_lirc_codec,lirc_mceusb
ir_core                12818  9
usbcore               117048  7

[root at mythbox ~]# cat /etc/conf.d/lircd.conf

IR RC5(x) protocol handler initialized
IR RC6 protocol handler initialized
Registered IR keymap rc-rc6-mce
input: Media Center Ed. eHome Infrared Remote Transceiver (1784:0001)
as /devices/pci0000:00/0000:00:1d.0/usb2/2-2/2-2:1.0/rc/rc0/input4
rc0: Media Center Ed. eHome Infrared Remote Transceiver (1784:0001) as
mceusb 2-2:1.0: Registered Topseed eHome Infrared Transceiver on usb2:3
usbcore: registered new interface driver mceusb
lirc_dev: IR Remote Control driver registered, major 250
IR Sony protocol handler initialized
lirc_mceusb: Windows Media Center Edition USB IR Transceiver driver
for LIRC 1.90
lirc_mceusb: Daniel Melander <lirc at rajidae.se>, Martin Blatter
<martin_a_blatter at yahoo.com>, Dan Conti <dconti at acm.wwu.edu>
usbcore: registered new interface driver lirc_mceusb
usb 1-4: reset high speed USB device using ehci_hcd and address 4
rc rc0: lirc_dev: driver ir-lirc-codec (mceusb) registered at minor = 0
IR LIRC bridge handler initialized

[root at mythbox ~]# lircd -v
lircd 0.9.0-pre1

[root at mythbox ~]# ps -ef |grep lircd
root      1531     1  0 18:41 ?        00:00:00 /usr/sbin/lircd -d /dev/lirc0

[root at mythbox ~]# cat /sys/class/rc/rc0/protocols
[rc-5] [nec] [rc-6] [jvc] [sony] [lirc]

I'm thinking it has something to do with the event layer grabbing
stuff before it gets to lircd, but I can't seem to turn switch that
off.  There must be some magic that I am missing.  Would this also
explain why some keys seem to be intermittent???    Here is the output
from pressing OK, 1, 2, 3.

[root at mythbox ~]# irw
0000000000001783 00 3 Hauppauge_350
0000000000001783 01 3 Hauppauge_350
0000000000001783 02 3 Hauppauge_350

I am using my trusty /etc/lirc.conf file that worked flawlessly before
# this config file was automatically generated
# using lirc-0.5.5pre8 on Sun Apr 18 11:43:45 1999
# contributed by Jens Leuschner <leuschner at gmx.net>
# brand:             Hauppauge
# model:
# supported devices: WinTV primo; WinTV pci; WinTV radio

This did not improve the situation, BTW:

echo none > /sys/class/rc/rc0/protocols
echo +lirc > /sys/class/rc/rc0/protocols

I'd appreciate any help as I am at my wits end.  Thanks in advance.

More information about the mythtv-users mailing list