[mythtv-users] tearing my hair out with audio over hdmi

Jean-Yves Avenard jyavenard at gmail.com
Wed Mar 9 23:26:41 UTC 2011


On 10 March 2011 02:18, Matt Harrison <iwasinnamuknow at genestate.com> wrote:
> I've googled for days, tried upteen different settings and nearly gone
> bald and I still cannot get audio over hdmi working on this nVidia ION
> chipset. I'm running Gentoo mainly but I have exactly the same result
> with Mythbuntu LiveCD (And I'm just about to try an XBMC livecd just in
> case -- hey, i'm desperate).
> I've made tiny bits of progress here and there which (reading many many
> MANY forum posts) should mean it is working, but no.
> Is there anyone here who has managed this? someone who would be willing
> to go through some things with me and get this working.

Is it an ion or an ion2 chipset ?

The ION has broken multichannel output over hdmi ; so the channels
order will be mixed up.

The ion vs ion2 difference is important.
With the ion, there's pretty much nothing to do as there's only one hdmi device.

With the ion2 (and GT2xx, 3xx and 4xx) there are multiple hdmi devices
actually present, and you'll find that only one work.

Based on your trouble, I would assume you have the ion2 as the ion is
very easy to set up.

The easiest for you to get the latest version of ALSA: both the driver
and the library: latest version is 1.0.24 ...
You can check which version you have installed with:
cat /proc/asound/version

Earlier version of alsa would have required you to set up a custom
.asoundrc and play with the hardware card and device number.

Forget what some people have suggested related to this: there's no
need to take this approach.

Once you have installed 1.0.24 drivers *and* library (the library is
the most crucial bit here); you can test which device to use.
the name will be something like: hdmi:DEV=n (with n = 0 to 9).

Try them all with speaker-test with:
speaker-test -c 2 -Dhdmi:DEV=x

try until you hear something; you'll know then it's the one to use.

In mythtv you then select the same audio device as the one you've found to work.

> The HDMI output shows up fine in "aplay -l" and "aplay -L", I can use
> speaker-test or aplay on the card/device with no errors. I've tried
> muting/unmuting everything in alsamixer (several analog related channels
> plus 3 s/pdifs). It all _appears_ to work fine. It's just silent.

In the BIOS, did you enable hdmi audio ? I know that on my 9400M
board, by default it is disabled and instead used a realtek chipset.
The hdmi would show up fine ; but no sound would come up.

> Analog audio works without problems but no matter what I try I cannot
> get HDMI working.
> I would be so grateful if someone could help, I'm literally about to
> throw it all out of the window thanks to all these smug ubuntu people
> saying how easy it was to get working on the forums :P

If you update the alsa drivers and library to 1.0.24 ; you more than
likely will find that it works right away with just the "hdmi" device.

More information about the mythtv-users mailing list