[mythtv-users] Slightly OT: ATI Remote Wonder with Fedora 15

Josh Mastronarde jmastron at gmail.com
Thu Jun 30 18:28:33 UTC 2011

On Thu, Jun 30, 2011 at 5:14 AM, John Welch <jrw3319 at gmail.com> wrote:
> On Wed, Jun 29, 2011 at 11:52 PM, Jarod Wilson <jarod at wilsonet.com> wrote:

>> I committed the fix in upstream lirc and backported it to the 0.9.0-6.fc15
>> package on June 6th, and the -7 build I just pulled down shows atilibusb
>> in the lircd -H help output. What seems to be the problem, officer?

> Well, in simplest terms my remote just doesn't work like it used to
> before I upgraded to F15.  Some keys (up, down, left, right) work, but
> most do not.  Let me do some more checking on my end.  Maybe I changed
> something in my original troubleshooting steps and forgot to change it
> back.  If you say the issue is resolved in the lirc package then the
> problem is most likely on my end.

John, are you using the original remote control, or a different one
(either a remote from another device, or universal remote emulating
another device)?  The problem I'm having with F15 and mceusb, where my
actual remote control is using some old Philips VCR code set, is
similar -- some keys respond (and then only sometimes), most don't.  I
isolated Myth as not being part of the issue --  I ran irrecord, and
it seems to think there are different timing/gap parameters than on
F14 or F11, and times out when teaching it most buttons.

I haven't dug further in yet (just decided to go with F14 for now, to
get the main Myth installation from 0.21->0.24), but from some
Googling, it sounds like F15 lirc has some change to the way the codes
and tables are compiled in for only the "native" remote for the
receiver.  But I don't fully understand the relationship between the
lirc kernels, drivers, codes, etc; I hope to work on that once I get
the main Myth transition done.


More information about the mythtv-users mailing list