[mythtv-users] Weird old-frame problem editing recordings, but only at 5+ second jumps (even after .24 +fixes upgrade) *SOLVED*

Kingsley Turner krt at krt.com.au
Thu Jun 30 04:26:51 UTC 2011

On 30/06/11 12:00, Mark Kendall wrote:
> On 30 June 2011 09:43, Kingsley Turner<krt at krt.com.au>  wrote:
>> On 30/06/11 10:03, Kingsley Turner wrote:
>>> On 29/06/11 18:37, John Pilkington wrote:
>>>> On 29/06/11 01:09, Kingsley Turner wrote:
>>>>> I have this problem with the MythTV video editor/trimmer thing.
>>>>> When I step through the video at 1-frame, 0.5 seconds, or 1 second
>>>>> everything is OK.
>>>>> However when I step through at keyframe, 5 seconds (or more) the image I was
>>>>> viewing before pushing [right-arrow] (or [left]) obscures the new frame
>>>>> image.  However I do see the correct frame for a split-split-second before
>>>>> the old one obscures it.  So the 'cursor' is advancing through the video,
>>>>> but I can never see exactly where I'm up to.
>>>>> That sounds a bit convoluted - here's an example.
>>>>> Say I have a news recording before a program I want to trim off.  On my
>>>>> screen I see the face of the news-anchor-dude.  I set the jump to 1 second,
>>>>> and press [->] and the cursor advance, and a new video frame is shown (it's
>>>>> still the same guy though).  All this is correct.
>>>>> So I up the jump time to 5 seconds, press [->].  I see a screen flash of the
>>>>> new frame, but it's immediately covered by the frame I started on (the news
>>>>> reader).  I push [->] about 10 times.  As I do it, I can see the cursor
>>>>> advance, and a flicker of the correct frame (into my nature-programme now),
>>>>> but every time that original news reader image is back.  I set the jump-time
>>>>> back to 1 second, and it works fine.
>>>>> I had this problem with 0.23, but had hoped it would go away with 0.24.  It
>>>>> hasn't.  It's a real problem with the keyframe jump.  I want to trim every
>>>>> last peice of the previous programme away, but this problem makes it really
>>>>> difficult - almost trial and error.
>>>>> I run the nvidia-binary driver - NVIDIA-Linux-x86-260.19.29.  But various
>>>>> upgrades to this driver have yielded no resolution.
>>>> My memory of this is rather hazy:  I used to see behaviour a bit like
>>>> this with the editor, although I don't  recollect anything
>>>> 5-second-specific.  I think it had to do with the video-blitter
>>>> settings, or maybe it was Qt vs GL.  I don't see it now, and a quick
>>>> look at the frontend settings hasn't shown anything that clicks.
>>>> In my nVidia X server XVideo settings I have the Video Texture and Video
>>>> Blitter both synced to VBlank on the monitor, and  OpenGL _not_ synced
>>>> to VBlank, with flipping allowed.  These settings may not make any
>>>> sense, but if they differ from yours they may be worth trying.
>>> I replicated your nVidia settings, but to no effect I'm afraid.
>>> I might have a play with the Qt/GL settings and see if anything comes of it
>> Hmm ... nothing changes do with switching Qt<->  OpenGL rendering either.
>> Guess I need to re-install from scratch or something.  Might wait a few more
>> years yet ;)
> Perhaps related to http://code.mythtv.org/trac/ticket/9719

Hey ...  it was!

I checked my deinterlacing settings after reading that, and found I had it 
set to "None".
(NB: I don't remember ever having it set to that.  It must have changed in 
an upgrade or something?)

I changed it to <can't remember> but the little help window Myth said that 
was the default.
Now it all works ... *SO* happy to have keyframe selecting again!  Woohoo!

many many thanks,

More information about the mythtv-users mailing list