[mythtv-users] Problem playing Blu-Ray rip

Michael T. Dean mtdean at thirdcontact.com
Tue Jun 21 16:44:30 UTC 2011

On 06/21/2011 10:32 AM, Trey Blancher wrote:
> I am trying to play a video from my video library (not from a storage
> group yet), and it won't play if the script is launched from within
> the MythTV frontend.  The frontend just hangs, and I need to use an
> external shell to kill the mythfrontend.real process.  Here is the
> output of "mythfrontend --version":
> MythTV Version   : v0.24.1-20-g7c2c249
> MythTV Branch    : fixes/0.24
> Network Protocol : 63
> Library API      : 0.24.20110505-1
> QT Version       : 4.7.2
> Options compiled in:
>   linux debug using_alsa using_oss using_pulse using_pulseoutput
> using_backend using_bindings_perl using_bindings_python using_dvb
> using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv
> using_ivtv using_joystick_menu using_lirc using_mheg
> using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit
> using_v4l using_x11 using_xrandr using_xv using_bindings_perl
> using_bindings_python using_mythtranscode using_opengl using_vdpau
> using_ffmpeg_threads using_live using_mheg
> I'm using a combined frontend/backend, and the .BDiso file is shared
> from my NAS via NFS.  I've also attached my script.  It's designed to
> mount a BD ISO file (ripped with SlySoft AnyDVD HD), and then issue a
> command to the running frontend (using the network control interface)
> to play the root directory of /mnt/iso/.  If the frontend is running,
> and I execute the script from a shell outside of the frontend, the
> frontend begins to play the video just fine.  I've renamed all the BD
> ISOs I have from .iso to .BDiso, so the frontend will select my script
> rather than the usual .iso handler.  The command I use for the BDiso
> file type is "~/scripts/playbd.sh %s", but I've tried
> "/home/mythtv/scripts/playbd.sh %s" and it still doesn't work.  When I
> select one of these .BDiso files through the mythfrontend GUI, it
> simply hangs, accepting no more keyboard input until I switch to a
> running terminal and killall mythfrontend.real.  If I start
> mythfrontend in a terminal, the last line of output is always this
> when it hangs:
> 2011-06-21 09:09:01.511 Locking input devices
> I don't see any obvious errors or warnings above that, and it doesn't
> look like it even tries to execute my script.  I can provide the full
> standard output, for the working and non-working cases.  If the
> internal player could read BD ISOs directly I wouldn't have this
> problem.
> Thanks in advance!

You need to return a successful exit status from the script that's 
called by MythVideo so that MythTV knows it's "done" with your external 
player and can start responding to requests, again.  This means 
MythVideo needs to run an "intermediate" script, which runs /and 
backgrounds/ the script you're currently having MythVideo run, and then 
exits, so your current script continues after MythTV is told it can 
start responding to requests, again.

Or, you can just put the BluRay file system into a directory (rather 
than wrapping it up in an ISO) and let MythTV do everything for you...


More information about the mythtv-users mailing list