[mythtv-users] Got my Ceton infiniTV 4...any else have one yet?

Ronald Frazier ron at ronfrazier.net
Sat Jun 18 18:39:34 UTC 2011

I was just wondering if anyone here has a Ceton infiniTV 4 card yet
and what their experience has been so far. Because it has a rebate
going and is almost as cheap as the HDHR Prime, I decided to take a
chance and go buy one (knowing full well that it would be a bit of a
rocky road being an early adopter). I've been playing with it for a
few days now and it works pretty well on it's own outside of myth.
Right now, I haven't yet upgraded my cable package, so I don't
actually have a cablecard. Thus for now I'm simply playing with it's
ability to work as a digital tuner. I didn't want to pay the extra to
upgrade my service until I figure out how to get this thing working
like I want.

It has a nice web interface, and it's really easy to capture from.
Just 'cat' the output from /dev/ceton/ctn91x_mpeg0_# entries and
redirect it into a .mpg file, and those files are playable in mythtv.
Austin from Ceton emailed me the specs for the DRI UPnp interface,
though I haven't yet had a chance to look through it much.

As far as the web interface, the way the ceton works is that it create
a new pseuo-network device in linux called ctn0, so you essentially
have 2 network cards. The ceton web server then acts as if it were
running on another computer attached to that 2nd network interface
(ie: it has its own separate IP address). So all you do is configure
the 2nd network card to come up with any IP address on the
192.168.200.* subnet (except for .1)...so for example,
Then you connect your web browser to on port 80 and you
get the card's web interface. I wanted to try and make this website
available outside my linux box (since I primarily use windows). I
spent about 4-5 hours trying to understand how to configure network
bridging and get it to work, but I was never successful. I could get
the bridge setup, it would say it worked, and everything would look
fine (at least to me, though I have no experience with the matter),
but every time it came up, I could neither connect from the linux box
to any outside box nor to the Ceton card, nor could any outside
devices connect to the linux box nor the Ceton web server. I'm not
sure what I'm doing wrong there. If anybody has been able to get this
working, I'd love to know how you did it. So for now, I'm just using
an SSH tunnel from my windows box to the linux box, which then
connects to the interface

As far as myth, I know it's not yet supported, but I've heard a few
mumblings on this list and elsewhere about daniel's branch where he's
working on it, so I though I'd give it a shot. First thing I did was
poke through the new code in lib/libmythtv/ocur*. I noticed in
ocurchannel.cpp, there was a variable called using_cable_card that was
hardcoded to true. I set that to false (since I'm not yet using a
cablecard). Everything compiles fine and mythtv-setup recognized and
allows me to configure all 4 tuners just fine. However when I go to
scan for channels, it fails. Knowing how the data should be entered, I
went and manually put a couple channels in the database hoping to make
it work. However, when I start up mythbackend it complains of the

OCURChan(, Error: Invalid device, should be in the
form uuid:recorder_number

Not sure if this can be worked around or not yet. Maybe I can retrieve
the uuid from the DRI interface and manually stick that info into the
DB to make it work for now. Haven't tried that yet (just thought of it
now as I'm typing).

I also took a shot to see if I could get it working under 0.24-fixes
instead (this was actually my first attempt...before I tried upgrading
to daniel's dev branch). I figured maybe I could hack it in somehow
using the demo recorder or import recorder feature. My thinking was, I
could use the Myth System events for Recording Started/Stopped to
trigger a backend script that does the tuning via HTTP calls to the
web server and point myth to the /dev/ceton/* entries. Before I got my
ceton card, I gave this method a try with my PVR-500, and it worked
like a charm with the Demo Recorder, so I was hoping all would be
well. However, the Demo Recorder didn't work with the ceton for some
reason. I tried using the same technique but on the Import Recorder
instead but no luck there either. Then I tried using the Input
Recorder with no file specified, and having my channel changing script
also start catting the /dev/ceton/* output to the recording file. I
was able to get it to work for the first program, though there was a
pretty big delay of 5 seconds or so when starting LiveTV. However,
when I went to change channels, it would crap out for some reason. It
appears my event script never got called, and then the frontend would
just fail out of Live TV mode. So much for hacking it in.

So anyone else had any luck getting it working somehow, either through
daniel's branch for another hack? Perhaps someone has had better
results using a cablecard. If so, then I'll just have to make a leap
of faith and upgrade my cable service first under the assumption I'll
be able to get it working.

Ron Frazier

More information about the mythtv-users mailing list