[mythtv-users] OS X 10.7 Xcode 4.1

Andre mythtv-list at dinkum.org.uk
Fri Jul 29 15:41:03 UTC 2011

On 29 Jul 2011, at 16:23, Matthew Smith wrote:

> Has anyone tried to build 0.24 on OS X 10.7 with Xcode 4.1 yet?

I've not built 0.24 but I do know that the binaries I'm running work fine on 10.7 Lion, in fact a long standing bug seems to be fixed. When Flash acceleration has been used prior to starting Mythfrontend on an Nvidia GPU Mac the Mythvideo flashes red fullscreen between video frames, not very pleasant.

I use the Sourceforge binaries.


> I've got a mac mini on the way and want to compile both front and backends on it. I've built mythtv on a variety of linux flavours over the past six years, but never before on a mac, and poking around the messages on this list, it looks like this is potentially a mess.
> For starters, I remember life was always easier with nvidia and mythtv on linux, and see that the mac has a radeon HD 6630M.
> I also note that OS X 10.7 sounds like a messy mix of 64 and 32 bit code, and of course has only been in userland for a week along with Xcode 4.1.
> Anyway, if anyone is able to share experiences about flags that need to be passed when compiling, failed dependencies etc. it'd be appreciated.
> For example, I see from the wiki (http://www.mythtv.org/wiki/Building_MythTV_on_Mac_OS_X) that GCC 4.x may not be able to compile mythtv and that GCC 3.3.3-7 modules might be needed. Is this still the case? I see the OS X wiki hasn't changed since March.
> Will I need to force a 32-bit build to get mythtv to compile or can I build 64-bit versions of dependencies like LAME?
> Thanks, and I'll share my experiences once the machine is up and running.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list