[mythtv-users] I got my Ceton InfiniTV 4 working in 0.24-fixes (compiled with custom code)

Ronald Frazier ron at ronfrazier.net
Thu Jul 28 16:01:41 UTC 2011

> Indeed LIRC is the very next thing it complains about.  So those error messages were related to the LIRC and not the stream. Okay, solved those error messages with that mplayer preference trick, thanks for that.  But the net result is still the same: nothing.  mplayer just hangs there when trying to start.  I know mplayer works fine for me for other things.  I just tested and it is working fine for stuff I ripped.  So I may still not be getting the stream from the card correctly.  Will require more debugging, then.  Thanks for confirming you are using the same command and of course thanks for helping me realize that the errors I was seeing aren't related to the Ceton stream.

OK, here is what you need to do to tune it using QAM. First, you need
to know a channel that is available in QAM mode, and you need to know
it's frequency. The frequency should be 6 digits. If you have 9
digits, remove 3 zeros. If you've only got 3 digits, add 3 zeros on
the right. You'll also need to know the modulation. I've personally
never seen anything other than QAM 256. I'm not even sure what the
other choices would be for. Once you have this info entered, hit the
Tune button.

The page should reload and the select box labeled Program: should pop
up with a list of channels available on the tuned multiplex. If you
don't get anything, then either you entered an invalid frequency, you
forgot to hook up the coax cable, or something else is wrong somewhere
(bad cable line or bad card).

Once you get a list of programs, select one and click the Set Program
button. The page will again refresh, and you should see the frequency,
modulation, and program all filled in. Carrier lock and Digital lock
should both be 1 (I don't recall for sure, but I think one or both of
them should have turned to 1 after the Tune step)

Once you've got it tuned and a program selected, and you see the lock
status, go back to the Status tab for the tuner. Look at the very
bottom at the Copy Protection: section. I believe it will say "None",
but I don't recall correctly (when you have a cablecard, it always
seems to say "Copy Control Information: "Copy Free" (00)", even if
it's an unencrypted QAM channel)

If that checks out, you should just be able to cat the /dev entry and
pipe it into mplayer. However, note that the /dev entries are numbered
starting with zero, so tuner 1 is /dev/ceton/ctn91xx_mpeg0_0, and NOT
/dev/ceton/ctn91xx_mpeg0_1. That mistake will get you no data and
mplayer will sit there waiting :)

Ron Frazier

More information about the mythtv-users mailing list