[mythtv-users] Ceton InfiniTV 4 and patches to support it

John Haller john.h.haller at gmail.com
Sat Jul 23 13:48:25 UTC 2011

I tried out Ron's patches, and it works fairly well, except for one problem,
which is probably not associated with his patches.

The picture will tear, jump, or pixelate, which is generally associated with
the X process using close to 100% of one core, and the following message
repeated in the myth front end log:
2011-07-22 15:59:11.236 [mpeg2video @
0x7fdf1e7d57a0]mpeg_decode_postinit() failure

Single stepping the video one frame at a time has the same problem.

I recorded the same show off the antenna at the same time, it's close to the
same size (5.50 GB - cable vs 5.52 GB - antenna)

The kernel log was also full of messages like:
notify_cc_check:41 WARNING: (0) NOTIFY board 0 tuner 0 pid 0x1d77
out_of_sync 2000
This message comes out of the Ceton driver when packets don't start
with the start
of packet indicator 0x47, and is happening quite a bit. I rebooted,
the out-of-sync
messages stopped, but still get the pixelation.

So, I'm not sure if my problem is with the card dropping packets, causing the
decode to choke on the missing packets, or something else. With the antenna,
the CPU for X associated core runs at 100% for about 10-15 seconds, then
is less than 5%. For the Ceton recording, it's similar, but about 38 seconds in,
I start seeing chunks of the picture in places it doesn't belong, and the
CPU spikes to 100% again. I suspect the picture is not synchronized,
and whatever causes the X associated CPU to spike at the beginning of
the playback is kicking in again.

The only other thing which might be a problem is that the tuners run
close to the
65C max (62.8). The signal level is -10.5 dBmv, signal to noise of 36.0 dB. But,
I put a fan on it, got it down to 38C, and still lots of dropped packets. But,
clear QAM off the other splitter tap works fine going directly into the TV.

After the reboot, now I get these messages in mythfrontend log (just a
sample, there
are more of these message):
2011-07-22 18:39:17.461 Player(0): Video timing method: USleep with busy wait
2011-07-22 18:39:17.461 TV: Changing from None to WatchingRecording
2011-07-22 18:39:17.496 VideoOutput: Created YV12 OSD.
2011-07-22 18:40:22.197 AFD Error: Unknown decoding error
2011-07-22 18:40:22.247 AFD Error: Unknown decoding error
2011-07-22 18:42:37.933 Player(0): Waited 100ms for video buffers
2011-07-22 18:42:37.941 Player(0): Waited 100ms for video buffers
2011-07-22 18:44:32.052 Player(0): Timed out waiting for frames, and
                        there are not enough free frames. Discarding
buffered frames.
FYI, the front/backend is a Core i7 860 @2.8 Ghz.


More information about the mythtv-users mailing list