[mythtv-users] Help - Lirc broken after upgrade to 0.9.0

Jeff Cranmer jeff at lotussevencars.com
Sat Jul 23 04:15:03 UTC 2011

On Fri, 2011-07-22 at 23:49 -0400, Jeff Cranmer wrote:

> > On Fri, 2011-07-22 at 22:46 -0400, Eric Sharkey wrote:
> > > On Fri, Jul 22, 2011 at 10:45 PM, Jeff Cranmer <jeff at lotussevencars.com> wrote:
> > > > I just solved my own problem.  The LIRC_DEVICES="mceusb" needed to be
> > > > changed to LIRC_DEVICES="devinput"
> > > 
> > > That doesn't sound right to me.
> > > 
> > > Make sure that you can see your remote key presses using "irw".  You
> > > should be able to do that even without X working.
> > > 
> > > Eric
> > 
> I'm actually more concerned with sending right now, as I need to send a
> signal to the receiver from the PC to control it.
> Sadly, that isn't working yet, as I'm getting an irsend error, hardware
> does not support sending.
> I have a dish-change-channel-lirc.sh script which sets 
> DEVICE="-d /dev/lircd"
> REMOTE_NAME="dish211"
> a typical command is 
> I checked the /etc/lirc/lircd.conf script, and I had lost my dish211
> channel changer settings.  I recovered those, and now I see a listing
> for the dish211 remote name when I type irsend list "" ""
> I still get the same 'hardware does not support sending' error when I try to send though.
> Where to next?
> Jeff

Reply from Eric

> That's right.  The devinput driver is only for (wait for it...) input.
> Try running lircd by hand: /usr/sbin/lircd --device=/dev/lirc0 --nodaemon

> If you don't see any errors, then try your transmitting script in 
> another window/console.

Previously, I used LIRC with only the mceusb LIRC devices option set in
make.conf.  Now that driver is defunct, and there is a devinput driver
which only half-replaces it.  The obvious question is 'what replaces the
transmitter?'  Do I need to add another option to LIRC_DEVICES in
make.conf to pull in the transmitter driver?

Running the lirc daemon by hand, the messages were 
lircd(devinput) ready, using /var/run/lirc/lircd
accepted new client on /var/run/lirc/lircd
initializing /dev/lirc0
can't get exclusive access to events coming from the '/dev/lirc0'

running irsend -d /var/run/lirc/lircd SEND_ONCE dish211 select 
gives the same error as before - hardware does not support sending.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20110723/5cfd45ea/attachment.html 

More information about the mythtv-users mailing list