[mythtv-users] Technotrend C-2300, LOCK but no data on encrypted channels

Mattias Vik magion at gmail.com
Thu Jan 20 11:45:42 UTC 2011

On Thu, Jan 20, 2011 at 11:38, Jan Schneider <jan at horde.org> wrote:
> Zitat von Mattias Vik <magion at gmail.com>:
>>>> Hi!
>>>> I have a Technotrend C-2300 which have been working great with MythTV
>>>> on Mythbuntu 9.04 for both FTA and encrypted channels.
>>>> About two weeks ago I decided to reinstall my HTPC and install Gentoo
>>>> instead, as that is the distro I usually prefer... but whatever I tried,
>>>> I just
>>>> couldn't get the C-2300 to work with encrypted channels.
>>>> I tried kernel 2.6.32, 2.6.34 and 2.6.36, and I always get a lock on
>>>> the encrypted channels, but there seems like I get no data.
>>>> So I then tried installing Mythbuntu again, but now I can't get it to
>>>> work with that either, it's the same error.
>>>> I have tried every Mythbuntu version from 8.04 to 10.10, and whatever
>>>> I do I just get the same result.
>>>> So then I tried to put in my old Technotrend C-1500 instead, and with
>>>> that I get LOCK and picture/audio, but, for some reason
>>>> that card only get about 55% signal, whereas the C-2300 always get
>>>> atleast 80%... so some channels are unwatchable with the C-1500.
>>> That's common problem of (at least certain) Technotrend cards that have
>>> massive tuning problems.
>>>> Can someone please give me some more advice on what I can try to get
>>>> the C-2300 to get data on encrypted channels again?
>>>> (btw, I've tried every firmware I could find for it, all with the same
>>>> results)
>>>> I'm starting to think that the card somehow is broken... which would
>>>> be odd, as all I did was reinstall, and it works perfectly for FTA
>>>> channels.
>>>> Mplayer says it gets a TS stream, but on encrypted channels it just
>>>> hangs there, whereas on FTA channels it finds video and audio and then
>>>> plays the stream.
>>>> I've also tried with both CI and softcam, and it says it gets the
>>>> correct key and LOCK, but still no data.
>>>> I'm out of ideas!, all suggestions are welcome.
>>> I completely gave up with TT cards at one point because they are buggy
>>> not well supported. Switched to KNC and never looked back.
>>> Of course this is not an answer to your question, and you at least seemed
>>> to have the 2300 working in the past, so it's indeed strange that it doesn't
>>> work anymore after the re-install.
>>> Did you do any hardware changes at the same time? Are you using separate
>>> CIs for the 1500 and the 2300?
>>> Jan.
>>> --
>>> Do you need professional PHP or Horde consulting?
>>> http://horde.org/consulting/
>> I didn't change any hardware except adding one harddrive when I did
>> the reinstall, which I think would be very strange if that would do
>> any difference on the dvb card.
>> Yes, it's separate CI's, the one for the C-1500 is internal, and the
>> one for the C-2300 is for 3,5"... but I only have one Conax module and
>> card from my cable provider, so can only use one at a time.
>> I think the easiest solution is probably to buy a new DVB-C tuner (and
>> not a Technotrend this time!)... is there any other internal (PCI or
>> PCIe) full feature dvb-c cards besides the TT C-2300?
>> Found this one:
>> http://www.dvbshop.net/product_info.php/info/p2258_Mystique-CaBiX-C2--DVB-C--HDTV--CI-Connector--Windows-Linux.html
>> says it's the same as the KNC ONE...
>> but nowhere does it say if it's a FF or Budget card.
>> I still think it's very weird I can't get it to work though, as I did
>> have it working before the reinstall... but I'm tired of messing with
>> this now, have reinstalled 10+ times the last two weeks trying to get
>> it to work... and I can say the gf's patience with not being able to
>> watch TV is starting to run out (I'm lucky most channels also make the
>> shows she's interested in available for free on the web).
> Just a dumb question: but since you are using the same CAM in both CIs, are
> 100% sure you are putting the CAM in correctly? It fits very well in both
> directions, at least in the TT CIs, but only in the correct direction you
> are able to push it completely in. This happened to me once, lesson learned.
> Jan.
> --
> Do you need professional PHP or Horde consulting?
> http://horde.org/consulting/
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Thanks for the suggestion, but I'm quite sure it's in the right direction.
I've had it working before, first with the C-1500, and then since 2008
with the C-2300.
It works on the C-1500 (but with very bad signal), and I get a LOCK
with the C-2300, just no data.
But I'll check what you suggested again, just to be absolutely sure.


More information about the mythtv-users mailing list