[mythtv-users] Technotrend C-2300, LOCK but no data on encrypted channels

Greg Oliver oliver.greg at gmail.com
Wed Jan 19 19:24:23 UTC 2011

On Wed, Jan 19, 2011 at 1:16 PM, Mattias Vik <magion at gmail.com> wrote:
>>>> Hi!
>>>> I have a Technotrend C-2300 which have been working great with MythTV
>>>> on Mythbuntu 9.04 for both FTA and encrypted channels.
>>>> About two weeks ago I decided to reinstall my HTPC and install Gentoo
>>>> instead, as that is the distro I usually prefer... but whatever I tried, I just
>>>> couldn't get the C-2300 to work with encrypted channels.
>>>> I tried kernel 2.6.32, 2.6.34 and 2.6.36, and I always get a lock on
>>>> the encrypted channels, but there seems like I get no data.
>>>> So I then tried installing Mythbuntu again, but now I can't get it to
>>>> work with that either, it's the same error.
>>>> I have tried every Mythbuntu version from 8.04 to 10.10, and whatever
>>>> I do I just get the same result.
>>>> So then I tried to put in my old Technotrend C-1500 instead, and with
>>>> that I get LOCK and picture/audio, but, for some reason
>>>> that card only get about 55% signal, whereas the C-2300 always get
>>>> atleast 80%... so some channels are unwatchable with the C-1500.
>>> That's common problem of (at least certain) Technotrend cards that have massive tuning problems.
>>>> Can someone please give me some more advice on what I can try to get
>>>> the C-2300 to get data on encrypted channels again?
>>>> (btw, I've tried every firmware I could find for it, all with the same results)
>>>> I'm starting to think that the card somehow is broken... which would
>>>> be odd, as all I did was reinstall, and it works perfectly for FTA channels.
>>>> Mplayer says it gets a TS stream, but on encrypted channels it just
>>>> hangs there, whereas on FTA channels it finds video and audio and then
>>>> plays the stream.
>>>> I've also tried with both CI and softcam, and it says it gets the
>>>> correct key and LOCK, but still no data.
>>>> I'm out of ideas!, all suggestions are welcome.
>>> I completely gave up with TT cards at one point because they are buggy not well supported. Switched to KNC and never looked back.
>>> Of course this is not an answer to your question, and you at least seemed to have the 2300 working in the past, so it's indeed strange that it doesn't work anymore after the re-install.
>>> Did you do any hardware changes at the same time? Are you using separate CIs for the 1500 and the 2300?
>>> Jan.
>>> --
>>> Do you need professional PHP or Horde consulting?
>>> http://horde.org/consulting/
>> I didn't change any hardware except adding one harddrive when I did
>> the reinstall, which I think would be very strange if that would do
>> any difference on the dvb card.
>> Yes, it's separate CI's, the one for the C-1500 is internal, and the
>> one for the C-2300 is for 3,5"... but I only have one Conax module and
>> card from my cable provider, so can only use one at a time.
>> I think the easiest solution is probably to buy a new DVB-C tuner (and
>> not a Technotrend this time!)... is there any other internal (PCI or
>> PCIe) full feature dvb-c cards besides the TT C-2300?
>> Found this one:
>> http://www.dvbshop.net/product_info.php/info/p2258_Mystique-CaBiX-C2--DVB-C--HDTV--CI-Connector--Windows-Linux.html
>> says it's the same as the KNC ONE...
>> but nowhere does it say if it's a FF or Budget card.
>> I still think it's very weird I can't get it to work though, as I did
>> have it working before the reinstall... but I'm tired of messing with
>> this now, have reinstalled 10+ times the last two weeks trying to get
>> it to work... and I can say the gf's patience with not being able to
>> watch TV is starting to run out (I'm lucky most channels also make the
>> shows she's interested in available for free on the web).
>> Thanks for your reply.
>> /Mattias
> Forgot to ask, will the CI-interface I already have for the C-1500 or
> C-2300 work with the Mystique/KNC card, or do I need buy a new one?
> I also found a "Digital Devices DuoFlex CT Dual DVB-C/DVB-T", but I
> haven't found any definitive answer anywhere if this card will work in
> Linux.
> Would be great if that would work... it's possible to get 2, 4 or 8
> tuners on one PCIe x1 with that one.
> I found that there is a CI-interface that supports MTD (Multi
> Transponder Decrypting), I've never heard of that before... does it
> work with a Conax CAM? (I live in Sweden and have Com Hem as my cable
> provider).

I wanted to say this originally, but now I must..

"I also *had* a fully working system, which stopped, so now I need
some help.."  If you cannot move your system back to its original
state, then too bad..  But please do not try to craft help messages to
forward your *lack of* needs..

There are other forums for this..  If you in fact (like you said)
cannot get it to work again with the exact same software, then it
tells us you never had it working and are just fishing for help on a
public list that does not support it..

More information about the mythtv-users mailing list