[mythtv-users] FC14, lirc_mod_mce, MS MCE Keyboard. Anybody have this working?

Derek & Cindi Cass cass at casscoenterprises.com
Wed Jan 12 04:19:56 UTC 2011

Blacklisting mceusb did the trick.  Thanks Jarod!

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Jarod Wilson
Sent: Monday, January 10, 2011 5:09 PM
To: Discussion about MythTV
Subject: Re: [mythtv-users] FC14, lirc_mod_mce, MS MCE Keyboard. Anybody
have this working?

On Jan 9, 2011, at 2:13 PM, Derek & Cindi Cass wrote:

> Hello all, I've been trying to get a MS Media Center Keyboard working
> with my recently built FC14 based Mythbox.  I downloaded the latest
> lirc_mod_mce and after working through the compile issues needed due to
> changes in the 2.6.35 kernel, I was able to successfully install the
> kernel module and use irw to verify that the extended keyboard buttons
> worked (Play, Stop, etc.) although none of the standard keyboard keys
> worked.
> And after the next reboot, it no longer works and hasn't since.
> Historically, lirc_mod_mce conflicted with lirc_mceusb2, but
> lirc_mceusb2 and lirc_mceusb were merged in lirc as of v0.8.6.  I have
> tried lirc 0.8.5 (with a blacklisted lirc_mceusb2) through 0.8.7 to no
> avail.

Blacklisting lirc_mceusb2 won't do a heck of a lot of good on a Fedora
14 install, since it has no lirc_mceusb2, as well as no lirc_mceusb.
Its got the new mceusb driver (no lirc_ prefix).

> The instructions for lirc_mod_mce said to run three steps with dkms and
> then "configure lirc".  The only choice with lirc that seems appropriate
> in the setup script results in mceusb/2.  Looking at solutions for
> ubuntu, it seems that I should be trying to use lirc_mod_mce as the
> driver which is configured in /etc/lirc/hardware.conf, but fedora
> doesn't use this, and the stated option is
> REMOTE_MODULES="lirc_mod_mce", but REMOTE_MODULES isn't listed
> in /etc/sysconfig/lirc (which I assume is the equivalent
> to /etc/lirc/hardware.conf in fedora - maybe I'm wrong).

Equivalent-ish. These are distro-specific pseudo-config files that alter
the behavior of their respective lirc initscripts.

> lircd -H=? has never shown lirc_mod_mce as an available driver,

Nor will it ever. lirc_mod_mce is a kernel driver. lircd lists lircd
drivers. lirc_mod_mce falls under 'default'.

> and if I
> force it to use this in /etc/sysconfig/lirc lirc won't start.  lsmod
> does show lirc_mod_mce loaded.
> Anybody have any ideas?

For starters, I'd try blacklisting mceusb and see if that gets you
any further.

In the long run, I plan to integrate the keyboard functionality into
the mceusb driver, but that work keeps getting delayed by a myriad
of other issues.

Jarod Wilson
jarod at wilsonet.com

mythtv-users mailing list
mythtv-users at mythtv.org

More information about the mythtv-users mailing list