[mythtv-users] jamu.py fails if I exclude directories in jamu.conf

Matt Beadon matt.beadon at gmail.com
Tue Jan 4 20:12:40 UTC 2011

I'm running mythbuntu 10.04 x86_64 with 0.24-fixes and ever since I upgraded
from 0.23 I've had trouble with jamu.

I was able to narrow down the cause but now I'm stuck.  At the end of my
jamu.conf file I have:

> [ignore-directory]

#ignore00: /test

ignore01: /usr/tv-shows/Home Movies

If I run jamu.py (even just jamu.py -MVf) I get this error:

> Traceback (most recent call last):

  File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 6422, in <module>


  File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 6390, in main


  File "/usr/share/mythtv/mythvideo/scripts/jamu.py", line 1290, in
> setUseroptions

    self.config['ignore-directory'].append(unicode(cfg.get(section, option),
> 'utf8'))

TypeError: decoding Unicode is not supported

If I comment out that ignore01 line above jamu runs properly.  Also this
file worked in 0.23 with the ignore directories.  Has the syntax for
jamu.conf's ignore section changed?  Is anyone else successfully using the
ignore section with 0.24?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20110104/6c910089/attachment-0001.htm>

More information about the mythtv-users mailing list