[mythtv-users] LIRC on FC14 Mythtv .24 Both LIRC and Built In Running - Help?

Michael Jones mythtv at michaelandholly.com
Tue Feb 22 22:16:44 UTC 2011

In efforts to get current, add a few capabilities to my system and gain a
little more stability I've recently wiped my MythTV BE system and installed
FC14 ( and MythTV .24. from ATRPMS    So far I
have "almost" everything working. 


One of the misbehaving components is LIRC .. Whenever I press a remote key,
I get at least 2 keypresses in the UI.  I'm guessing this is due to both the
imbedded LIRC support in .24 and LIRC running together?  How do I turn the
imbedded version off? 

I've tried:  


echo none +lirc > /sys/class/rc/rc0/protocols


which results in: 


[root at frontend rc0]# cat protocols


[rc-5] [nec] [rc-6] [jvc] [sony] [lirc]


This option doesn't seem to make any difference.  


I've also seen a thread on this where Jarod and others were discussing this
issue and mentioned pointing lirc at /dev/lirc0 - not exactly sure what they
meant here (simple symbolic link in the /dev directory maybe?) 


I can disable LIRC but when I do, not all of the keys on the remote work.  


At this point I see 2 options:  


1)      Disable LIRC and work with the built in LIRC Support  - Only if I
can figure out how to get the keys to work properly 

2)      Disable the built in LIRC support and revert to LIRC - only if I can
get the built in LIRC to quit interfering


Any instructions?  Links?  Insights? 


The other issue is a burst of static at the beginning of playback.. but I'll
have to address that one later.. I've heard it's caused by something in



Thanks LOTS



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20110222/44d721fb/attachment.html 

More information about the mythtv-users mailing list