[mythtv-users] Firewire recording/configuration difficulties

GZ gzornetzer.lists at gmail.com
Sun Feb 6 20:32:36 UTC 2011

On Sun, Feb 6, 2011 at 10:48 AM, Brent Meyer <brent.meyer at gmail.com> wrote:


> I am in Seattle, WA, using Comcast cable. I only attempted to record
> the OTA channels, all of which I have verified are flagged copy-freely
> and are unencrypted. My cable box is a Pace RNG110.
> My backend runs Mythbuntu 10.04.1 (kernel 2.6.32), using the older
> firewire stack. I have also tested Mythbuntu 10.10 (running kernel
> 2.6.35 and the newer juju firewire stack) on a different disk on the
> same machine, with similar results. My firewire card is a cheapo Syba
> card with a VIA VT6307 chipset.
> <snipped>

> I did the following:
> $ plugctl -n 1 "oPCR[0].n_p2p_connections=1"
> $ sudo chmod 666 /dev/raw1394 (on the 10.04 installation only; this
> doesn't seem to apply to the new stack)
> $ test-mpeg2 -r 1 > test.mpg (dozens of times, all with the same result)


> I've also tried dozens of combinations of models/transfer rates in the
> backend setup, all with basically the same results.
> I'm hoping this is just a case of a cheap firewire card not working
> properly. Can anybody out there tell where I've gone wrong?
Hi Brent,
I'm also in Seattle with Comcast (and the RNG-110).
One question - I couldn't tell from your post if you tested the output of
test-mpeg2.  Does it have lots of macro-blocks and errors?  Did you try
playing it in myth as well as other players (VLC or mplayer)?

Although I haven't upgraded my backend to use firewire, I've been testing it
out with recent Fedora live USB images.  I can comfirm that the output of
test_mpeg2 is clean on my system.  At the very least, it plays in mplayer
without nasty blockiness.  I've heard that some people have problems with
the firewire output from the RNG-110 working in mplayer but not in mythtv.
IIRC, the RNG-110 in some cases outputs non-standards-compliant streams,
something out nonexistant PMT tables. you should be able to find it with
google.  I cannot remember if I've tested for this.  I'll see if I can do
this tonight.

For your information, I'm using a PCI firewire card with a TI chip (it's an
old adaptec card), so I would point the finger at your VIA chipset.  Another
possible problem (that I had) is that older versions of the firewire drivers
had some problems on 64 bit machines.  Are you running a 32 bit or a 64 bit
kernel?  I'd highly recommend a live USB image for checking these sorts of

Good luck - and remember that you're not alone in the Seattle Comcast saga.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20110206/054c8a26/attachment.htm>

More information about the mythtv-users mailing list