[mythtv-users] FW: Help understand the interface of Myth Media & Video Gallery

John Pilkington J.Pilk at tesco.net
Thu Feb 3 14:28:37 UTC 2011

> <snip>

> But he also reported an unhelpful response from  'sudo chown' and, later,
> that the apparently successful changes he had made had been spontaneously
> reverted.
>> I typed the following in the terminal " sudo chown -R mythtv:mythtv
>> /media/Store/Recordings"
>> And I got the following error - Missing operand after mythtv
>> /media/Store/Recordings
> I haven't used sudo, but its man page clearly isn't designed for the
> newbie: is the response above to be expected given the likely default
> settings for sudo?  I imagine that su would have worked?
> And is the non-stick behaviour likely to be linked to this comment from
> jedi?
>>     /media seems like an odd place be putting your files.
>>     This is generally where Ubuntu mounts removable media.
> John P

 > So you can see from this brief background I never decided to mount my new
 > partition in media and I can take your advice as correct that this is 
not a
 > good place to have it but thats where the system set it up.  I guess 
this is
 > what it is like for new user when they are learning.
 >> From my perspective there is nothing odd about putting files in a spare
 > partition and /media/Store is the path to the location so your comment
 > thought welcome is not fully understood.  Where do you suggest they 
 > be mounted?
 > Many Thanks
 > Anthony

Hi Anthony:  I've snipped quite a lot of this and moved your response to 
the end of this post; that (bottom posting) is the convention on this 
list and makes for a quieter life.

I posted my followup because I wasn't sure why you still had these 
problems and I was looking for some clarification.  I only saw one 
reply, from Andre, which you have presumably seen too.

It looked to me as if the chown thing should have worked, unless you did 
split it onto more than one line; and Andre said that, at least in 
Ubuntu, 'media' _was_ subject to system-initiated changes.  So perhaps 
you ought to move your /Store/Recordings folder to 
/mnt/Store/Recordings. That would probably require you to edit 
/etc/fstab - which will again need root privileges. If you run into 
difficulties with this you really need to consult the Linux/Ubuntu docs 
- but perhaps by now you _have_ found out how to mount filesystems :-)

Good luck,

John P

More information about the mythtv-users mailing list