[mythtv-users] Fedora 16 for mythTV

Alec Leamas leamas.alec at gmail.com
Mon Dec 12 12:46:27 UTC 2011

Hi all, sorry for late reply, busy doing other things...

[gaberubin at gmail wrote]

> I used preupgrade, or should say tried to. I got bit with the /boot
> partition not being big enough. If anyone can advise as to how to
> increase the /boot partition, that would be great.
In the  Fedora README,  have you seen the  section on how to handle a to 
small boot partition? Look for preupgrade_filler. It has saved me 
several times.

> There is a new way to start/stop/restart certain services. I know
> have to use "systemctl [start/stop/restart/status] [service]" as
> opposed to "service [service] [start/stop/restart/status]". Again,
> wish there had been something on the fedora upgrade page to note this.
> If there is, I was looking at the wrong page. 

The new way is 'systemd', and it's actually quite well documented :)

> irexec does not always load up automatically. I have no idea why, or
> at least, had no idea until I read Alec's email. I don't know if it
> is the same issue that Alec has and I need to add code, or it is
> related to my lirc problem described next. Last time I rebooted, lirc
> and irexec were working properly, so I think irexec just didn't work
> because lirc wasn't loading properly. I will explore further, but
> Alec, how did you solve? 
My hack to start and run irexec  below. The proper way to solve this, 
and the non-working auto-login after logout, is to define a systemd 
services and targets, using 'wants' and 'before' conditions.  I might do 
that, later on. But the hack seems to work ATM.


while [ "$state" != 'active' ]; do
     state=$( systemctl show -p ActiveState lirc.service | cut -d= -f2 )
     [ "$state" == 'inactive' ] && echo "irexec: waiting for lircd"
     sleep 1

pids=( $( pgrep irexec ) )
kill ${pids[@]/$$/}

echo "Starting irexec"
while :; do
     irexec &
     echo "Restarting irexec"

> I am having issues with lirc that I have detailed in two other
> threads. My PVR-350 receiver used to always be in the same
> /dev/input/eventX (where X was 6, I believe) so I could put that line
> in /etc/sysconfig/lirc; however, this is no longer static and on
> reboot, I have to find out which event file it is and modify the
> config file and start up lirc. Sometimes, I get lucky and it is the
> right eventX on reboot. I believe when this happens, irexec starts up
> properly, but as I said, I need to investigate further. So far,
> suggestions from the list have not solved the problem (but I very much
> welcome them).

You might  possibly  use udev to create a fixed  device  symlink.  
Search for e. g., 'udev create device symlink'.

> On some reboots, the mythbackend service does not start properly. Now
> looking at Alec's post, I am thinking it is because mythfrontend was
> starting before mysql service started. This seems to have resolved
> itself (not sure how), but if it pops back up again, it would be good
> to know how Alec specifically fixed that (not sure how to add code to
> make the frontend wait for mysql to start). 

Hack below, don't forget to modify db passwd to what you really are using.


while (( status != 0 ))
     mysql -u mythtv --password=mythtv mythconverg << EOF &> /dev/null
     sleep 1
     if (( status != 0 )); then
         echo "Waiting for mysqld";

> Finally, as to Alec's issue with not being able to auto-log back in, I
> have a button to do a "soft reset" of myth (short of a reboot) when
> things go haywire that uses irexec to execute a script that issues
> "sudo killall gdm-binary" with the mythtv user having the correct
> permission to perform this. This kills gdm, gnome, mythfrontend, etc,
> and just logs back in. I think it just basically restarts x.

Thanks for that, should work and I will try!

However, a possibly cleaner way would be to define a new systemd target, 
something like runlevel 4 in the old init parlance. This would just run 
startxfce without messing with gdm at all, and systemd could restart it 
as required. I think this is might be the right way  to do it in the 
long run, to use systemd instead of fighting it :)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20111212/ccb7ca35/attachment.html 

More information about the mythtv-users mailing list