[mythtv-users] LIRC problem after mythbuntu upgrade

Yianni Vidalis yiannividalis at hotmail.com
Sun Dec 4 16:07:30 UTC 2011

> Date: Sun, 4 Dec 2011 08:13:29 +0000
> From: mlt at etruscott.co.uk
> To: mythtv-users at mythtv.org
> Subject: Re: [mythtv-users] LIRC problem after mythbuntu upgrade
> I've tried  what I could see on the ubuntu site and I don't seem to be 
> getting anywhere with this as most of them seem aimed at old versions 
> and I understand that the way it has handled by the kernel has changed 
> completely.
> is their any advice on trouble shooting, before my remote become a big 
> stick...
> On 22/11/11 20:30, mlt at etruscott.co.uk wrote:
> > I have just updated my system to the latest mythbuntu, and it has 
> > killed my remote - which is a mceusb via lirc.
> >
> > irw doesn't seem register any key presses and the red led indicator on 
> > the receiver is almost permanently on, which makes me think that 
> > somehow the kernel thinks it is something else...
> >
> >      cat /proc/bus/input/devices gives:
> >
> > I: Bus=0003 Vendor=0471 Product=0815 Version=0000
> > N: Name="Media Center Ed. eHome Infrared Remote Transceiver (0471:0815)"
> > P: Phys=usb-0000:04:00.0-1
> > S: 
> > Sysfs=/devices/pci0000:00/0000:00:1c.5/0000:04:00.0/usb3/3-1/3-1:1.0/rc/rc0/input4
> > U: Uniq=
> > H: Handlers=kbd event4
> > B: PROP=0
> > B: EV=100013
> > B: KEY=fff 0 200108fc32e 237605100000000 0 700158000 419200000001 
> > 9e968000000000 10000000
> > B: MSC=10
> >
> > This seems sane to me, but what do I know or I wouldn't be asking the 
> > question.
> >
> >
> >
> >
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users
I am resending this message with all text files sent to pastebin because it got hold awaiting moderator's approval.

I resently entered the lirc world with mceusb on opensuse 11.4. I will 
tell you the steps I took and I hope some or all apply to mythbuntu.
 is not a guide, its a -from memory- list of the things I did to have my
 lirc up and running, and since it is for opensuse, maybe not everything
 will apply in your case.

I needed the ir-keytable program which for opensuse is in the v4l-utils package, but maybe mythbuntu provides it on its own.

When I run it, it shows:
# ir-keytable 
Found /sys/class/rc/rc0/ (/dev/input/event5) with:
        Driver mceusb, table rc-rc6-mce
        Supported protocols: NEC RC-5 RC-6 JVC SONY LIRC 
        Enabled protocols: RC-6 
        Repeat delay = 500 ms, repeat period = 33 ms

You need the RC-6 protocol for mceusb (the type of protocol in mine is written in the battery compartment, very convenient).
 the output of the ir-keytable command is not as above, i.e. the driver 
is not mceusb and the table doesn't include rc6, you have to run:
#ir-keytable -c -w /etc/rc_keymaps/rc6_mce -p RC6,LIRC

The /etc/rc_keymaps/rc6-mce file is included in the v4l-utils package, or the one that includes ir-keytable for mythbuntu.

 kernel is, which includes the mceusb module. So - 
and you've probably heard it by now - you need lirc 0.9.0 which doesn't 
provide it's own mceusb module any more.

I copied the whole modules folder just in case I'd mess things up:

sudo cp -dpR /lib/modules/`uname -r` /lib/modules/`uname -r`backup

Download the latest lirc from www.lirc.org and extract the source

$wget http://sourceforge.net/projects/lirc/files/LIRC/0.9.0/lirc-0.9.0.tar.bz2/download

$tar jxvf lirc-0.9.0.tar.bz2
$cd lirc-0.9.0

$./configure --with-driver=devinput --with-transmitter (the second option is if you want to use an ir-blaster, too)

If all goes ok, the last of the output will be:

"Your hardware does not require a special LIRC kernel module.

Now enter 'make' and 'make install' to compile and install the package."

Do as it says, 
$make && sudo make install

You have to find which device is your ir-receiver:
Mine is:

$la /dev/input/by-id

Total 0
drwxr-xr-x 2 root root 120 Δεκ   3 17:35 .
drwxr-xr-x 4 root root 240 Δεκ   3 17:35 ..
lrwxrwxrwx 1 root root   9 Δεκ   3 17:35 usb-05af_Rx504B_Ver:3.03-event-kbd -> ../event0
lrwxrwxrwx 1 root root   9 Δεκ   3 17:35 usb-05af_Rx504B_Ver:3.03-event-mouse -> ../event1
lrwxrwxrwx 1 root root   9 Δεκ   3 17:35 usb-05af_Rx504B_Ver:3.03-mouse -> ../mouse0
 1 root root   9 Δεκ   3 17:35 
 -> ../event5

The last device (usb-SMK_CORPORATION_MCE_TRANCEIVR_Emulator_Device_2006_PA100707131807G-event-if00) is the one I use.

 doesn't use /etc/lirc/hardware.conf. Instead it uses an  
/etc/sysconfig/lirc file for lirc initialization. I will include it 
because some variables will be the same

my /etc/lirc/lircd.conf:
cat /etc/lirc/lircd.conf

include "/etc/lirc/mceusb.conf"

 installed the lirc-remotes package which installed under /usr/share a 
lot of lircd.conf files for various remotes. I copied the 
/usr/share/lirc/remotes/mceusb/lircd.conf.mceusb file to 
/etc/lirc/mceusb.conf and I am including it to /etc/lirc/lircd.conf
 configuration file for mceusb includes two remote definitions, mine 
works with the OBSOLETE one, and this is the one I am including.

my /etc/lirc/mceusb.conf

 hope I covered all the necessary steps. Try to run lirc without 
daemonising it, to see the output of the command. Substitute the device 
with yours:

lircd --nodaemon --output=/var/run/lirc/lircd 

if it doesn't complain, there should be a /var/run/lirc/lircd socket created.
Try irw...
 it sees your keys being pressed, then all is ok. Find the relevant 
mythbuntu startup scripts and set the variables to the successfull ones.
 Try starting it as a daemon and see if you have success.

Good Luck.

Lastly, I am including my /home/mythtv/.lircrc file, which I have customized, so check it before you decide you want to use it.
# cat /home/mythtv/.lircrc
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20111204/31d14b9c/attachment.html 

More information about the mythtv-users mailing list