[mythtv-users] Shutdown command failing

aaron memoryguy at gmail.com
Wed Aug 31 21:53:53 UTC 2011

On Wed, Aug 31, 2011 at 15:40, Rodney Morris <rodamorris at gmail.com> wrote:
> This is just a shot in the dark, but does your sudoers file have the
> "requiretty" option enabled?  If so, comment the entry out.  I know
> that problem plagued me for a few days when setting up my Fedora based
> combined FE/BE.

Thank you, this is a great suggestion... Now that I think about it, I
recall that I ran into issues some months ago when there was an update
to the sudo package (I forget if it was a security update or what),
but I recall that I started having a problem with shutdown after
installing that patch... it seemed to be prompting for the user
password, even though my sudo configuration is set to allow the myth
user to execute commands without a password. After reverting back to
the previous sudo version the problem went away. I wonder if it could
be the same problem, but now the new "myth_system" framework is hiding
the prompt output.

I checked my sudoers file and I don't see the "requiretty" option
mentioned anywhere. The man page leads me to believe that this means
the option is *not* enabled (am I wrong? :) ). I see that I also tried
to address the previous problem by adding (or maybe commenting out? my
comments are not descriptive enough :(  ) "Defaults visiblepw":

# re-enable password-less behaviour with no-terminal (ie/ from mythbackend)
#Defaults visiblepw

But as I recall, whatever it was that I tried... didn't help.

Perhaps I will try reverting to the old sudo package again and see if
that helps..... here's hoping it doesn't totally hose everything....

Thank you so much for your input. At least it gives me something else
to look into. :)


More information about the mythtv-users mailing list