[mythtv-users] Shutdown command failing

aaron memoryguy at gmail.com
Mon Aug 29 23:52:23 UTC 2011


I hesitate to open a bug report for this, because I have a feeling
it's something I'm doing wrong, or it's a software failure outside
myth, or... something...

I finally got a chance to upgrade my system from Slackware 13.0 to
13.37 on the weekend. I would have left well enough alone, but I
seemed to need to upgrade in order to update to a more recent version
of Trunk, to test the fix for the memory leak I reported and/or to
collect additional data.

I'll spare you the details, but suffice it to say I spent almost the
entire weekend trying to get the system back into working order, but
there are still a couple of outstanding issues. I am in the process of
acquiring new hardware for a new system build, so hopefully these
issues won't be a problem for too long....

Anyway, one of the problems I have is that the Idle Shutdown seems to
be failing now. As far as I can tell, it's the same I've been using
since I enabled idle shutdown back in 2006:

ServerHaltCommand = sudo /home/myth/bin/nvshutdown

where nvshutdown is a shell script:
/sbin/lilo -R Halt

The entries in the backend log seem to indicate that the script is
returning "1" (rather than the expected "0" for success). When I run
the script manually I get return code 0, so I can't figure out where
the 1 is coming from. So I updated the above setting to, instead, run
the two commands directly:

sudo /sbin/lilo -R Halt && sudo /sbin/reboot

But still no luck:

2011-08-29 19:16:11.578696 N [4740/4756] Scheduler scheduler.cpp:2774
(ShutdownServer) - Running the command to shutdown this computer :-
						sudo /sbin/lilo -R Halt && sudo /sbin/reboot
2011-08-29 19:16:11.580475 I [4740/4756] Scheduler system-unix.cpp:703
(Fork) - Managed child (PID: 5272) has started! * command=sudo
/sbin/lilo -R Halt && sudo /sbin/reboot, timeout=0
2011-08-29 19:16:11.677561 I [4740/5256] SystemManager
system-unix.cpp:313 (run) - Managed child (PID: 5272) has exited!
command=sudo /sbin/lilo -R Halt && sudo /sbin/reboot, status=256,
2011-08-29 19:16:11.677761 E [4740/4756] Scheduler scheduler.cpp:2783
(ShutdownServer) - ServerHaltCommand failed, shutdown aborted

(the above is with "-v system,idle")

Am I doing something wrong? Is there additional information needed?

I am running version:

myth at myth:~$ mythbackend --version
Please attach all output as a file in bug reports.
MythTV Version : v0.25pre-3258-g393db20
MythTV Branch : master
Network Protocol : 69
Library API : 0.25.20110827-1
QT Version : 4.7.0
Options compiled in:
 linux release use_hidesyms using_alsa using_oss using_backend
using_bindings_perl using_bindings_python using_bindings_php using_dvb
using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv
using_libxml2 using_libudf using_lirc using_mheg using_opengl_video
using_qtdbus using_qtwebkit using_v4l2 using_v4l1 using_x11
using_xrandr using_xv using_bindings_perl using_bindings_python
using_bindings_php using_mythtranscode using_opengl
using_ffmpeg_threads using_live using_mheg using_libxml2 using_libudf

I apologize for the sparse detail... I've been banging my head on the
wall with all sorts of problems all weekend and getting frustrated :(
I will be happy to provide any additional details, please just ask for
whatever you need.


More information about the mythtv-users mailing list