[mythtv-users] Comcast CableCard Info

Ken Truesdale kat at tiac.net
Thu Aug 11 01:45:47 UTC 2011

> Date: Mon, 8 Aug 2011 21:13:12 -0400
> From: Tom Bongiorno <two.bits.11 at gmail.com>
> Subject: Re: [mythtv-users] Comcast CableCard Info
> To: Discussion about MythTV <mythtv-users at mythtv.org>
> Message-ID:
> 	<CAObkmsVoJxgi1eTRdw6i4k5m1rcpLrHVJ6bkFcDF7pyOi_u+Qg at mail.gmail.com>
> Content-Type: text/plain; charset=ISO-8859-1
> On Sun, Aug 7, 2011 at 11:11 PM, Tom Bongiorno <two.bits.11 at gmail.com> wrote:
>> On Sun, Aug 7, 2011 at 2:38 PM, Tom Bongiorno <two.bits.11 at gmail.com> wrote:
>>> On Sat, Aug 6, 2011 at 11:36 PM, Steven Adeff <adeffs.mythtv at gmail.com>
>>> wrote:
>>> I called Comcast this morning and have now spoken with three engineers.
>>> ?They are essentially following the chain of systems responsible for
>>> triggering the outgoing?validation?message. ?I am now awaiting a callback
>>> from the local engineer responsible for the last system that actually sends
>>> out the validation message. ?I don't truly understand how staging happens or
>>> if a validation message will make this happen. ?The engineer did go through
>>> the process of removing and re-adding the card to my account. ?They
>>> attempted to send a validation message a few times.
>>> The last engineer informed me that they are purchasing a Linux box and a
>>> Ceton card to become familiar with the platform and card. ?I told them that
>>> they may want to purchase a PRIME while they were at it.
>>> -Tom
>> WE HAVE VALIDATION!!! ?I went out for a few hours and came home to the
>> message "Validated, validation message is received, authenticated, and the
>> IDs match those in the current binding". ?At this point, the engineers do
>> not know that it is working. ?They are expecting to talk to me tomorrow. ?I
>> will try to pick their brains about all the steps that they went though. ?My
>> goal is to come up with checklist for us to use when trying to get a CC
>> working under linux.
>> I did notice one big problem though. ?Nearly three dozen channels are
>> incorrectly marked as copy-once. ?I submitted my CCI scan (Sicklerville, NJ
>> 08081) to Ron Frazier's site. ?I had them fix these problems back when I was
>> using Firewire capture. ?When I got my HD-PVR, I stopped using the flakey
>> Firewire capture. ?Since then, Comcast has done major lineup changes. ?I
>> guess they screwed it all up again. ?I shot an email off to my trusty
>> Comcast contact from back then. ?I will also mention this to the engineers
>> tomorrow, but I don't think this is their area.
>> -Tom
> I was unable to get a detailed list of steps from the engineer.  He
> did say that he knows what went wrong and has put in a request for a
> fix.  Unfortunately, it may only affect my local Comcast.  He admitted
> that they have no formal procedure for adding a CableCard or to
> resolve problems.  They are figuring it out as we speak.  Yikes!  On a
> good note, they do have a dedicated group of CableCard engineers.
> My high-up contact at Comcast fixed ALL the channels that were
> incorrectly marked copy-once.  He got my email this morning and his
> "conditional access team" had it fixed by the afternoon.  Now that is
> what I call customer service!  I have submitted an update to Ron's
> site.
> Ron, I am not sure if you want to remove the old channel list or not.
> -Tom

I'll share my Comcast cable card activation tale too.  I got my CC at my local Massachusetts office - first location I tried.  They didn't have any "self install kits" but they said they had the cards.  After 10 minutes of poking around on the computer trying to find a code so she could give me one, there was an "a-ha" and she stuffed the card into a red envelope and handed it to me.  The envelope includes a pamphlet labeled "Xfinity TV CABLECARD Self-Installation Instructions".  I'm curious to know what the difference is between what I got and what a "self install kit" would have been.  (Maybe she made the kit on the spot but the kits come sealed from Comcast HQ?)  Also, I'm disappointed to report that my monthly fee for my new cable card will be $6.45.  I had been previously told by one person it would be $1.50 and by another that it would be free.  But apparently, because I already have a dvr STB, cable card is considered an "additional outlet".  I may still call and see if I can argue this point later.  

Back at home, I stuffed the card into the Ceton while booted under Linux.  (As it turns out, I never did need that Windows 7 install I set up but I guess it was good to have as a backup.)  I got all the info I needed from the Ceton screen and the handy pamphlet had a special phone number to call for cable card activation.  The number is 877-405-2298 and bounces to the Philippines.  The two times I called the number somebody answered right away asking how I could get excellent service for my activation.  So, it seems nice that they have a dedicated center for this.  On the other hand, things did not go well.  

The first person I talked to, Jay, punched in my info and told me to check back some time in 45 minutes.  Big shock: not activated.  I called back a couple hours later and talked to Aldren.  She ran through the numbers.  All were correct except the data number (I think) was missing the last digit.  (Reminds me of Steve Martin in My Blue Heaven.)  She updated the numbers and told me to wait on hold.  She said she could tell the the signal was sent so I should try again.  She kept asking if the channels were working and telling me to hit buttons on my remote.  Eventually I said "I don't have a remote" which baffled her.  She said "isn't this a TiVo?".  I said no, it was a Ceton card in a computer.  "Oh."  But then she didn't really seem to indicate that it was a problem or that it would change what she was doing.  More time on hold and eventually she told me she'd call me back in an hour to find out if it worked.  Two hours later it hadn't activated.  But by hour number 3 it had!  

The other weird thing to comment on is that I had two browser windows open to the Ceton card.  One was open and stayed static from when I first started trying.  The other I was refreshing routinely.  During the day, before the activation worked and while I was on the phone the second time, I realized that the content of the Ceton page had changed.  The field next to "Card Version" had changed from "817" to "1315".  Also, there was a new "Card Applications" at the bottom named "CANH status" that wasn't on the original page.  My assumption is that the card needed to receive a software update from Comcast and that may have slowed things down.  The newer version of the card apparently also comes with an additional application - the CANH thing, whatever that is.  

So I think a number of forces were at work here.  First, the first guy got my numbers wrong.  Second, the second call did get a software update started (or maybe it had already started) but the bad data may have corrupted some system.  Maybe activation from the Philippines takes longer than local?  The card did not look new and may well have been recycled from an STB.  I further suspect that a newer card might have had less "baggage" in the Comcast system and this recycled one I have may have taken some time to clear out what was there before.  

As for my success with MythTV - not yet.  As I mentioned in the other post, I'm still stuck with getting Myth to work with it.  But I've confirmed that I'm able to tune with the Ceton page and that I can see those channels in mplayer so that indicates I've got the cable card part all set up.  When I figure out that problem, I'll post that info.  


More information about the mythtv-users mailing list