[mythtv-users] How to make mythbuntu 10.4 system disk clone bootable?

Craig Huff huffcslists at gmail.com
Sun Aug 7 21:57:43 UTC 2011

Ok.  This shouldn't be so hard, but...

I have been searching with google and trying various methods with no
success.  Can someone tell me how to do this?

I had a running MythBuntu 10.04 FE that stopped booting.  I found
(once I switched from the S-video input to the VGA input with a *real*
monitor ;-) that the SMART system actually flagged the disk as dying.
I added a replacement disk hanging outside the case like a drunken...,
well you know.  Then I booted into the MythBuntu 10.04 install CD
trial mode.  I ran Synaptics, added gparted and used that to clone the
old disk onto the replacement.  The old and new disks are single EXT4
partitions for the O/S and another small (about 380MB) swap partition.
 I then used gparted to enlarge the O/S partition on the replacement
disk to use the rest of the available space (moved from a 4.3GB disk
to an 80GB).  I mounted the disk temporarily and browsed thru the
clone contents and it looks ok. I unmounted it and now I'm trying to
make it bootable but having no luck. My old notes were for grub, but I
believe this system uses grub2.  All I'm getting are complaints about
not finding a suitable partition.  Oddly, when I ran "grub-probe -d
/dev/sda1" I got back "ext2", but if I run parted, it tells me it's an
ext4 partition.  I've pretty much run out of ideas at this point.  Any
help making this clone bootable?


More information about the mythtv-users mailing list