[mythtv-users] Help configuring Flash 10.2.x in MythDora

Phusion phusion2k at gmail.com
Wed Apr 27 01:03:47 UTC 2011

I am running MythTV 0.24-2. The video card is an ASUS ENGT430. Video
and sound are working in MythTV. For video I'm using the 270.41.06
Linux 32-bit driver from NVIDIA. For sound I'm using compiled versions
of ALSA driver 1.0.24 and ALSA library 1.0.24. The Adobe Flash Plugin
is 10.2.159-1. The problem appears to be with the /etc/asound.conf
file. When I don't have this file, the Flash plugin plays video
without sound, but when I do have a file like the following the Flash
player freezes in Firefox and locks up. I'm able to hear a sample
sound using the following.

# aplay -D plughw:0,9 /usr/share/sounds/alsa/Front_Left.wav

Here is one of the many asound configurations I've tried that hasn't worked.

pcm.!default {
type hw
card 0
device 9

In MythTV the audio output device is as follows.


The thing I'm wondering is if there is a conflict between the compiled
ALSA library (1.0.24) and the installed RPM ALSA library (1.0.23-1). I
compiled the ALSA library 1.0.24 afterwards when the alsa-lib-1.0.23-1
was already installed.

# rpm -qa | grep -i alsa
# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.24.

Let me know. Thanks.


More information about the mythtv-users mailing list