[mythtv-users] frontend can't login into backend

Mike Bennett mbppg at comcast.net
Wed Apr 20 00:13:48 UTC 2011

On 04/19/2011 04:44 PM, R. G. Newbury wrote:
> On 04/19/2011 01:58 PM, Mike Bennett wrote:
>> On 04/19/2011 11:08 AM, Jim Morton wrote:
>>> On 4/19/2011 12:01 PM, Mike Bennett wrote:
>>>> On 04/19/2011 09:25 AM, Raymond Wagner wrote:
>>>>> On 4/19/2011 10:02, Mike Bennett wrote:
>>>>>> On 04/18/2011 02:18 PM, Mike Bennett wrote:
>>>>>>> On 04/18/2011 01:09 PM, Jim Morton wrote:
>>>>>>>> On 4/18/2011 3:00 PM, Mike Bennett wrote:
>>>>>>>>> On 04/18/2011 12:28 PM, Raymond Wagner wrote:
>>>>>>>>>> On 4/18/2011 14:19, Mike Bennett wrote:
>>>>>>>>>>> But when I try to get access to the backend from another frontend
>>>>>>>>>>> box using the correct mythtv user and password it says it can't
>>>>>>>>>>> login. Any ideas?
>>>>>>>>>> The backend protocol does not use username and password, MySQL
>>>>>>>>>> does. It
>>>>>>>>>> sounds like you have not set up the proper credentials for your
>>>>>>>>>> remote
>>>>>>>>>> machines.
>>>>>>>>>> _______________________________________________
>>>>>>>>> So how would I check? on both boxes it is mythtv and mythtv.
>>>>>>>> http://www.mythtv.org/wiki/Category:MySQL
>>>>>>> Thanks Jim I will give that a try tonight when I get home.
>>>>>> Okay I tried the info on resetting the passwords and still the same
>>>>>> thing. I verified that I had the pin set to 0000 in the general
>>>>>> setting
>>>>>> on the main myth setup. Now if I change the IP setting on the remote
>>>>>> frontend database ssetup to point to the host name myth.mbppg.com
>>>>>> instead of the actual IP then it seems to get past the login but
>>>>>> then it
>>>>>> says "cannot find (ping) database". If I uncheck the ping it stops
>>>>>> responding and I had to stop the backend and then rerun the remote
>>>>>> setup
>>>>>> and recheck the ping box then restart the backend just for the
>>>>>> screen to
>>>>>> show back up.
>>>>> Are you sure you have MySQL configured to listen on the network?
>>>> No how would I do that?
>>> Did you follow the link I sent?
>>> http://www.mythtv.org/wiki/Category:MySQL
>>> here is a clip of the pertinent entry
>>> Q: When running mysqlcheck I get the error message "Access denied for
>>> user ..."
>>> A: The problem may be that you are using the wrong password. The
>>> following commands will change the mysql password to "mythtv":
>>> # mysql -u root -p mysql
>>> myqsl>  GRANT ALL PRIVILEGES ON *.* TO 'mythtv'@'localhost'
>>> mysql>  UPDATE user SET Password=PASSWORD('mythtv') WHERE user='mythtv';
>>> mysql>  quit
>>> Note that you will have to change the database password in the mythtv
>>> setup to "mythtv" once you get it running again.
>>> end of clip
>> I did and it did not work, I ended up running this:
>> This example has no security at all, and allows access from any host.
>> ||
>> $ mysql -u root mythconverg
>> mysql>  grant all on mythconverg.* to mythtv@"%" identified by "mythtv";
>> mysql>  flush privileges;
>> and it did work. Not sure why the other one did not work, I must have
>> keyed in something wrong. But both frontend boxes are able to get to the
>> backend. Thanks.
> Because that particular formulation allows ANYBODY identified as mythtv
> on ANY machine, to get access to the mysql server.
> Which is exactly why Ubuntu and mythdora and many other distros do NOT
> allow remote access as the default setup.
> Kinda BIG security hole with that setup. Best fix it now!
> Geoff
Yes thanks for the replies, I was just trying to get it working at all 
first, then I can work on making it secure again. Problem is now the 
frontend tend to lock up. A new problem to solve.


Mike Bennett

More information about the mythtv-users mailing list