[mythtv-users] frontend can't login into backend

Joe Hickey jfwd at phlobus.net
Tue Apr 19 16:15:29 UTC 2011

On Tue, Apr 19, 2011 at 12:01 PM, Mike Bennett <mbppg at comcast.net> wrote:
>>> Okay I tried the info on resetting the passwords and still the same
>>> thing. I verified that I had the pin set to 0000 in the general setting
>>> on the main myth setup. Now if I change the IP setting on the remote
>>> frontend database ssetup to point to the host name myth.mbppg.com
>>> instead of the actual IP then it seems to get past the login but then it
>>> says "cannot find (ping) database". If I uncheck the ping it stops
>>> responding and I had to stop the backend and then rerun the remote setup
>>> and recheck the ping box then restart the backend just for the screen to
>>> show back up.
>> Are you sure you have MySQL configured to listen on the network?
> No how would I do that?

For the past couple releases of Ubuntu I've found the default
configuration for mysql either disables listening on the network or
listens only on the loopback interface.  Better for security, but
highly inconvenient for remote FE's.  Furthermore every time mysql
gets updated via normal updates it seems to revert to the default and
disable it again.

The file you need to check is "my.cnf" ... IIRC this is in /etc/mysql
on ubuntu (might be different location on fedora).

A quick verification can be done by going to a shell on your remote FE
and trying to log in via command line:
mysql -u <user> -h <ip> -p mythconverg

where "user" is the db user name (probably mythtv), ip is the master
backend, and it will prompt for the password.  If you get "access
denied" message or you can't connect at all, you know you have a
setup/permission issue with mysql.  If you are able to connect OK,
just quit and double check that the parameters are set the same in

More information about the mythtv-users mailing list