[mythtv-users] LIRC and MythBuntu 10.10

mlists mlists at dressler.ca
Fri Apr 15 15:49:59 UTC 2011

On 04/15/2011 11:24 AM, Mark Lord wrote:
> On 11-04-15 07:28 AM, Greg Hormann wrote:
> ..
>> I then tried to configure using serial port.  I copied over the
>> lircd.conf file from the old server, setup hardware.conf and restarted
>> the service.  The lirc_serial module seems to correctly load, but the
>> it doesn't change the channels.  (Unfortunately this blaster doesn't
>> light up like the HD_PVR, so I can't see if a signal is actually being
>> sent, but if I plug it back into the old mythserver it still works..)
> I didn't break it, but I can fix it.
> Grab this tarball, unpack it, and use "make clean install".
> Then reboot.  Presto, working lirc_serial blaster.
>       http://rtr.ca/lirc_serial_fixed.tar.gz
> Mind you, it only works as well as the code therein.
> I find it to be rather spotty when run on a busy mythtv system.
> Sometimes it works, sometimes it only partially works,
> depending upon how busy the rest of the system is.
> Someday I really ought to write a proper implementation for this thing,
> except I don't actually need/use it myself.
I just tried this because I can't get the lirc module to see my 
available serial port.  Everything was working fine until I upgraded to 
2.6.38.  I also use the v4l git (media_build).   I get this error:
[   24.867152] lirc_serial: disagrees about version of symbol 
[   24.867159] lirc_serial: Unknown symbol lirc_register_driver (err -22)
[   24.873145] lirc_serial: disagrees about version of symbol 

If the driver in v4l it consistently says my serial port is busy and run 
setserial - and yes, I run setserial to diable the uart.

Any suggestions?


More information about the mythtv-users mailing list