[mythtv-users] Question re: available SATA ports and linux software RAID

Mark Lord mythtv at rtr.ca
Mon Apr 11 12:51:13 UTC 2011

On 11-04-11 01:43 AM, f-myth-users at media.mit.edu wrote:
> I've also heard reports that some BIOSes or motherboards can't cope
> with more than two MV8's on the PCI bus.  (Simply wouldn't notice the
> third one.)  Haven't tried that yet; I have enough of them that I
> could pile them all into one machine and give it a try at some point...

The 6041/6081 chips do have some PCI-X errata that requires that
they be used ONLY on PCI(X) bus #0.  So if your mobo has a LOT of
PCI slots, then there's a danger that some of those slots might be
behind a secondary PCI bridge, and therefore not on "bus #0".

There's no limit in the sata_mv.c driver on how many boards, though.

If you have PCIe slots available, then I STRONGLY recommend getting
PCIe boards (Marvell 7042 chip) rather than 6042/6081 PCI(X) chips.
Way fewer errata being worked around, and you get FIS-based switching
as a bonus.

"FIS-based switching", as opposed to "command-based switching", means that
NCQ works transparently through port-multipliers, giving a slight performance
boost for fancy RAID arrays and the like.

> > I do have a bug report currently of hot-plug failing for one user
> > on that chipset (Marvell 6041/6081) with recent kernels. Not sure why yet.
> Hm.  I certainly tried it under Ubuntu 10.10 (2.6.35-28-generic, AMD64),
> and it worked for me.  I was able to hdparm -Y the drive and it spun
> down; scsiadd detached it and reattached it, and simply pulling the
> drive (with no mounted FS on it, of course) also appeared to work even
> if I didn't do either of those things, though I try not to do that.

That's "warm plug".  Hot-plug is when you simply umount the filesystem,
and then yank the SATA (or power) cable.  Then connect a replacement drive,
and Linux is supposed to find it all nice and automatically.

The report I heard was from a single user, who says that once in a while
hot-plug fails to notice the new drive, and nothing but a driver rmmod/insmod
will cure it.  Unconfirmed, still waiting for more info.

But quite possible I suppose.  The 6081 chip is not as nice about hot plug
as the 7042 is, but I thought I'd worked around all of the errata there.


More information about the mythtv-users mailing list